1

I am using raspberry pi(Debian Wheezy) with OpenCv 2.3.1. I tried to take video using e-CAM30_USB module but failed. I can take images. FFMPEG is on. But gstreamer tells the stream is unsupported.

 For this question Mr. ppumkin answered that

"The still pictures is a standard JPG encoded by the MJPEG encoder, that's why you can see it. I am sure gstreamer supports MJPEG and not sure about YUV2. But! It is possible that the MJPEG implementation for ARM (Pi) architecture could still not be supported.

Possibly gstreamer needs to ask the camera for MJPEG directly or something else needs to ask for it. I doubt YUY2 will work any good on the Pi.(At least it is not listed in any supported codecs - but MJPG is)

It is possible that you should use something other than gstreamer."

I heard about MJPG Streamer ,but don't know how I can use it. Could you say a better solution? or How can I port MJPG Streamer to raspberry pi?

2

If you are talking about the mjpg-streamer program as found on sourceforge, you can just install that using

apt-get mjpg-streamer

I have been using that on the Raspberry Pi for a couple of weeks now, and it works (most of the time). It sometimes hangs the Raspberry Pi, but I guess that has something to do with the USB communication (still investigating this). Also as the name suggests, you can only use webcams that output MJPG, YUV2 cameras will not work.

Once installed you'll need to use the experimental version, because this uses the V4L2 code and not V4L code (which is no longer supported in the latest kernels).

Note: I have been using several different distributions in the last months, so in the case the plain Debian distribution does not have the mjpg-streamer package, I know for sure that Bohdi Linux (Debian based) does provide this package.

  • Hi, I am sorry,I can't install mjpg-streamer pi@raspberrypi ~ $ sudo apt-get install mjpg-streamer Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package mjpg-streamer – sumith Sep 19 '12 at 10:21
  • Try to compile the source found here: link, it compiled without any major problems (remember use the experimental version) – ikku Sep 19 '12 at 12:21
  • I tried to install mjpg-streamer(experimental) in pi. But I don't know what to do after the following command . This remains a lot of time. If I tried to kill it shows errors for next command. pi@raspberrypi ~/mjpg-streamer/mjpg-streamer-experimental $ ./mjpg_streamer -o "output_http.so -w ./www" MJPG Streamer Version: svn rev: o: www-folder-path...: ./www/ o: HTTP TCP port.....: 8080 o: username:password.: disabled o: commands..........: enabled What can I do next? – sumith Sep 20 '12 at 6:25
  • 1
    I tried compiling the experimental version but I get a Segmentation fault: 'make: *** [mjpg_streamer.o] Segmentation fault' – tzippy Jan 15 '13 at 13:52
  • 1
    Segmentation faults from GCC are nearly always because of hardware errors (in this case not having anything to swap on and running out of memory on the RPi). – ikku Jan 15 '13 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.