0

After some trouble networking with my Pi, I've just flashed my SD card with a fresh version of Raspbian 2014-01-07. It boots up fine but does not connect via ethernet to my network. The network lights are off.

Should a default Raspbian install automatically connect to the ethernet network, without any configuration, and should the network lights be flashing? (If so, I think I'll just have to buy a new one…)


Edit

I've connected it via a router/ADSL modem.

  • Yes, if the network has stands compliant dhcp. With multiple Pis I just connect the ethernet cable and the built in dhcp client picks up an IP address. A standard netgear router is providing my dhcp with no extra setup. – rob Jun 9 '14 at 11:57
  • I also meant to say that lights should come on even without a valid IP address, the same way desktop network card have lights even when the PC is powered off. – rob Jun 9 '14 at 11:58
  • Clarify what you have connected to Pi to e.g. router pc etc – Milliways Jun 9 '14 at 12:28
  • @Milliways edited the question – Sparhawk Jun 9 '14 at 12:31
  • Thanks @rob. Please make it an answer, preferably with references if possible. – Sparhawk Jun 9 '14 at 12:31
2

Rasbian and at least earlier editions of Raspbmc have a DHCP client active as standard.

When an ethernet cable is connected correctly and the PI is powered then the "FDX" and "100" LAN LEDs should be lit. When connected to the network traffic is indicated via the "LNK" LED

http://www.raspberrypi-spy.co.uk/2013/02/raspberry-pi-status-leds-explained/

  • That link doesn't really back up the claim, but I'll +1 for now based on anecdotal evidence. – Sparhawk Jun 9 '14 at 23:55
  • Okay, I bought a new pi, and yes, it's enabled by default. Accepted. – Sparhawk Jun 12 '14 at 7:02
0

Yes a default Raspbian installation automatically sets you up on the network DHCP and yes the lights flash quite a bit. Type

ifconfig eth0

In a terminal to see your assigned IP address and if you are sending and receiving data. you can also try to ping an IP address also try netstat also try

ifup eth0

to enable ethernet

In my experience, the Raspberry can take quite a bit of abuse; before you get too melodramatic, it actually may be ethernet cable

  • The ethernet cable works fine on my other computer. I've also tried ifconfig and sudo ifup eth0 already, so I'm pretty sure I'm not being melodramatic. – Sparhawk Jun 9 '14 at 22:58
  • Has this cable worked with the pi before? I ask as some cables are cross-over cables. Usually you connect up-link to down-link, but cross-over cables allow up to up or down to down. All computers provide up-links, hubs are mostly down-links with zero or one uplink. Some modern devices have auto up-link, meaning that ports are up/down depending on what is needed. If the other computer has auto up-link and the cable is a cross-over, and the pi does not have auto up-link (I don't know), then you will be miss diagnosing. – ctrl-alt-delor Jun 11 '14 at 8:55
  • Yes, it worked fine previously. It's a "normal" cable. – Sparhawk Jun 12 '14 at 6:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.