1

So all of a sudden my Pi running Debian wont shutdown. I have to hard reset it for it to go down. I recently just added a script to check if the wlan0 has a connection.

I have updated the Pi but to no luck.

Any ideas?

fenlig@Green ~ $ sudo reboot
[sudo] password for fenlig:

Broadcast message from root@Green (pts/0) (Tue Jun 10 00:54:33 2014):

The system is going down for reboot NOW!
fenlig@Green ~ $ tail -f 5 /var/log/syslog
tail: cannot open `5' for reading: No such file or directory
tail: cannot open `/var/log/syslog' for reading: Permission denied
fenlig@Green ~ $ sudo tail -f 5 /var/log/syslog
tail: cannot open `5' for reading: No such file or directory
==> /var/log/syslog <==
Jun 10 00:47:56 Green ntpd[2355]: restrict: error in address '::' on line 38. Ignoring...
Jun 10 00:47:56 Green ntpd[2355]: restrict: error in address '::1' on line 42. Ignoring...
Jun 10 00:48:01 Green /USR/SBIN/CRON[2426]: (fenlig) CMD (raspistill -q 100 -rot 270 -o /home/fenlig/www/images/image.jpg -n && convert -pointsize 60 -fill red -draw "text 100,100 '`date`'" /home/fenlig/www/images/image.jpg /home/fenlig/www/images/image.jpg)
Jun 10 00:48:01 Green /USR/SBIN/CRON[2425]: (CRON) info (No MTA installed, discarding output)
Jun 10 00:54:33 Green shutdown[2450]: shutting down for system reboot
Jun 10 00:54:33 Green init: Switching to runlevel: 6
Jun 10 00:54:34 Green ifplugd(eth0)[1702]: Exiting.
Jun 10 00:54:35 Green ifplugd(wlan0)[1701]: Exiting.
Jun 10 00:54:40 Green /USR/SBIN/CRON[2620]: (fenlig) CMD (raspistill -q 100 -rot 270 -o /home/fenlig/www/images/image.jpg -n && convert -pointsize 60 -fill red -draw "text 100,100 '`date`'" /home/fenlig/www/images/image.jpg /home/fenlig/www/images/image.jpg)
Jun 10 00:54:40 Green /USR/SBIN/CRON[2619]: (CRON) info (No MTA installed, discarding output)
Jun 10 00:55:01 Green /USR/SBIN/CRON[2632]: (fenlig) CMD (raspistill -q 100 -rot 270 -o /home/fenlig/www/images/image.jpg -n && convert -pointsize 60 -fill red -draw "text 100,100 '`date`'" /home/fenlig/www/images/image.jpg /home/fenlig/www/images/image.jpg)
Jun 10 00:55:01 Green /USR/SBIN/CRON[2631]: (CRON) info (No MTA installed, discarding output)
  • do you back up your images? I asked because if may help you diagnose your issue by knowing what you did between the last successful back up and now. I know that it may be not the answer you are looking for but I have gone mad diagnosing these types of issues (because I am novice with Linux). Sometimes its easier to rollback to your last good backup. – PhillyNJ Jun 10 '14 at 0:07
  • Nope, I should probably learn how to :( – Simon Kay Jun 10 '14 at 0:12
  • Well the first lesson is always the most painful. Always backup your images. – PhillyNJ Jun 10 '14 at 0:15
2

there are a few obvious problems in your syslog:

  1. don't put 5 in your tail command, the correct command would be tail -f /var/log/syslog (no 5 anywhere in sight)

  2. install MTA for cron jobs to send you the feedback and error messages or redirect their output to /dev/null

  3. disable whatever raspistill you have in your cron table, it is preventing your RPi from shutting down

yeah, and there's something fishy is going on with your /var/log/syslog itself, it should never require sudo to access the file, check if permissions and ownership are correct:

-rw-r----- 1 root adm 9409 Jun 10 12:15 /var/log/syslog
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.