I used linux for many years and I'm good doing stuff with the terminal but now that I bought my raspberry and I installed raspbian on it, I can't install chromium. I tried to install it from repo but it is an old version (22) and I need a newer version to enter in web store and install "chrome remote desktop".

What can I do to solve this problem? It's very important for me!

  • 1
    As a matter of fact, no one was able to answer this question. The accepted answer doesn't provide a clear solution but rather a work around by installing an alternate browser.
    – zabumba
    Jun 5, 2015 at 12:29

3 Answers 3


You should be able to compile Chromium from source for ARM - there are some intructions on that here (probably)

To attempt running a newer version Chromium, first install Chromium from the repos to make sure all other packages and libaries (e.g. libnss3) are installed.

Then run these command to download and extract the (currently)* latest snapshot of Chromium:

mkdir Chromium
cd Chromium/
wget https://commondatastorage.googleapis.com/chromium-browser-snapshots/Arm/103408/chrome-linux.zip
unzip chrome-linux.zip

You should then be able to run ./chrome-linux/chrome and get Chromium running, unless like me you get this (or another) error:

./chrome-linux/chrome: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.15' not found (required by ./chrome-linux/chrome)

I think the focus by Debian has been pushed towards the next release of Debian (Jessie, the current version is Wheezy), so updated packages are less likely to turn up.

*To get the latest version, download the zip file inside the folder with the largest number here - the latest number is also shown here

I found the problem - wheezy, the currently stable version has libc6 version 2.13, and version 2.15 or above is needed for most Chromium ARM builds to work - you can see this in the above error, and the following when I tried installing chromium from a deb, which also resulted with a few other errors:

dpkg: dependency problems prevent configuration of chromium-browser:
chromium-browser depends on libc6 (>= 2.15); however:
Version of libc6:armhf on system is 2.13-38+rpi2+deb7u1.

chromium-browser depends on libglib2.0-0 (>= 2.35.9); however:
Version of libglib2.0-0:armhf on system is 2.33.12+really2.32.4-5.
chromium-browser depends on libudev1 (>= 183); however:
Package libudev1 is not installed.
chromium-browser depends on libnss3-1d (>= 3.12.3); however:
Package libnss3-1d is not installed.

An upgraded version is available in the next version of Debian, Jessie, but you will have to upgrade to that when Jessie is stable

As an alternative, you could just install Firefox Iceweasel...

sudo apt-get install iceweasel

There is some info here as to why it is called Iceweasel, it was something to with Debian (on which Raspbian is based) not liking Firefox's branding...

Note: I seem to be only able to get version 24.5 on my Pi, but Firefox Iceweasel still works.

  • 1
    Really thank you Wilf! I already tried to download the latest version of chromium for arm from your same link (I took it from official chromium website) and I don't know why but nothing appeared when I launched it from the shell. Anyway I can't use Iceweasel as I said because I need the google webstore to use chrome remote desktop. I gave up using rasp for this and I opted using a PC. Thank you again! Jun 11, 2014 at 0:26
  • 2
    Even after upgrading to Jessie stable, I wasn't able to install Chromium. This answer shouldn't have been accepted. It gives a few hints, but it does not provide with a solution
    – zabumba
    Jun 5, 2015 at 12:30
  • @joelmaranhao - instead of complaining, you could add what you tried (how you updated, what did not work etc)....
    – Wilf
    Jun 5, 2015 at 15:09
  • @wilf really I am not complaining. I appreciate your post. I am just stating a fact. Your answer doesn't resolve the question asked, hence it shouldn't have been accepted as so. Unless you know for a fact that it works a provide a full path. Not saying that your participation isn't interesting either and certainly It was worth sharing but again not resolving. And I don't have solution for this either, hence nothing to share here. You are the one complaining :)
    – zabumba
    Jun 5, 2015 at 15:26
  • I upgraded to jessie too, and download the chrome.zip. When I try to launch from command line, it gives the following error: ./chrome: symbol lookup error: /opt/vc/lib/libEGL.so: undefined symbol: glPointSizePointerOES
    – ceremcem
    Aug 20, 2015 at 9:55

You could also try Arch Linux for ARM (alarm) if running a different distro is an option for you. Since it is rolling release all packages are pretty up to date. And if not you still have the option to get it from AUR (arch user repository) with packer, yaourt or some other package manager or build it yourself as wilf already explained.


I went to here and it installed a repository with almost the newest version. Right now the newest version is Chromium 50 but it installs Chromium 49.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.