1

I did a fresh install of Wheezy and setup my Pi's to connect with WPA, it works fine but after a while the wireless drops. Seems to be during wifi load aswell as well.

I have 2 identical Raspberry Pi setups with identical Wifi devices.

fenlig@Green ~ $ lsusb
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter

I am using a 1000ma power supply and have tried a 2000ma which made no difference.

if i do a ifup it says its alread configured and a ifdown then a ifup fixes it.

fenlig@Green ~ $ ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:87:30:23:20:78
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Any ideas guys?

Thanks Fenlig

1

I struggled with exactly the same issue a few months ago. I have tried almost everything, super-ultra efficient power supplies as well. Dying of desperation I changed... USB power cable. Since then not a single problem appeared. The cords inside the original one were simply too thin to carry enough current.

P.S.: While searching the answer for my case, I run across plenty of power noise related threads. Be sure to check the whole setup in the different electrical environment.

  • I hope thats not the case but I will have to give it a try. While I hunt for a new cable to try is there anyway I can find logs for wireless activity? – Simon Kay Jun 11 '14 at 17:31
  • Does dmesg give you any output on your wifi dongle? You can also check the /var/log/ directory, esp. files: deamon.log & kernel.log for any NetworkManager lines. – FJaskolski Jun 11 '14 at 18:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.