0

again me :) I installed ArchLinux on my rasp B. After that, I installed transmission. I set the settings.json in a way that I can access it through the webgui. I can see the webgui when I go to //rasp_ip:9091. Now I wanted to start transmission automatically and if I give this command (as said in the doc https://wiki.archlinux.org/index.php/Daemon):

systemctl enable transmission

He starts at boot but accessing it through website he gives me the classic transmission error:

403: Forbidden. Unauthorized IP Address. ecc.

If I disable the autostart, reboot the rasp and launch manually the daemon, I can access it through website... It's like it's changing the settings.json file, is it possible? How can I solve it? Thank you all very much

UPDATE: Tried to give

ps aux | grep transmission

And I get

transmi+   114  0.1  0.5  25096  2396 ?        Ssl  19:07   0:00 /usr/bin/transmission-daemon -f --log-error
root       288  0.0  0.2   4080   952 pts/0    S+   19:14   0:00 grep transmission

I give this anyway after obviously stopped the daemon

nano ~/.config/transmission-daemon/settings.json

and I have this whitelist option

"rpc-enabled": true,
"rpc-password": "{3c060ff110366902b432b1c28c39dc714bba20e2LKR8ZSqD",
"rpc-port": 9091,
"rpc-url": "/transmission/",
"rpc-username": "",
"rpc-whitelist": "",
"rpc-whitelist-enabled": false,

again it doesn't function.

UPDATE 2:

I noticed that giving

ps aux | grep transmission

when I stopped the daemon and re-started it manually giving

transmission-daemon

I receive

root       277  4.5  0.4  26120  2324 ?        Ssl  19:51   0:00 transmission-daemon
root       285  0.0  0.2   4076   948 pts/0    S+   19:51   0:00 grep transmission

So what's transmi+ ?

1 Answer 1

1

I was reading the italian documentation page about transmission. Reading the english version I found the chapter: "Choosing a user" It says

Choose how you want to run transmission:
- As a separate user, transmission by default (recommended for increased security).
By default, transmission creates a user and a group transmission, with its home files at /var/lib/transmission/

So I gave

nano /var/lib/transmission/.config/transmission-daemon/settings.json

and I set the file :)

https://wiki.archlinux.org/index.php/Transmission

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.