2

Is it possible to upgrade occidentalis 0.2 with the latest wheezy upgrades to improve the distro performance with sudo apt-get update && sudo apt-get upgrade. Or can't I get the improvments if I don't have the "standard" debian distro?

Kind Regards

  • Well.. it seems to work! I did the upgrade and an additional upgrade for the rasp-config utility and there chose High overclocking to 950Mhz 1Ghz didnt work. All seems faster! – Christian Sep 20 '12 at 14:02
0

It should always be safe to run system packages updates with sudo apt-get update && sudo apt-get upgrade. Keep in mind, however, that the updates described on RPi front pages are done in firmware and (mostly) kernel.

Unfortunately, Occidentalis is not using official foundation kernel (and in facts this is the biggest changes in this distro). If you look on their repo, you can find that they didn't get that kernel changes yet so you will have to wait until they do.

The other way is to use official foundation kernel but you will loose most of Occidentalis unique features this way.

  • Is the kernel firmware? – Alex Chamberlain Sep 20 '12 at 12:16
  • It's commonly refereed as part of firmware in RaspberryPi community. This is because a lot of changes in kernel are related to changes in other firmware files and vice versa. They also share the same repository, called firmware. So i guess, compiled kernel files can be regarded as a part of firmware in general. – Krzysztof Adamski Sep 20 '12 at 12:18
  • Kernel is the core of the linux distro not the firmware. Firmware are the code who lies within the startup/boot sector of the cpu. – Christian Sep 20 '12 at 14:28
  • Firmware definition became much more blurry recently. And in case of raspberry pi, kernel is not always distro specific, some of them decided to use official foundation kernel as its base, probably because of how often it is changed with important patches. But it isn't really relevant. It's just a naming issue I have already fixed in my answer. And I already explained why I used this term - because it's very often used this way in our community, even if it may not be correct from technical perspective. – Krzysztof Adamski Sep 20 '12 at 16:48
0

Short answer after testing it my self is, it works!

After update and upgrade start raspi-config and update this. I could not get the 1Ghz to work but I got "high mode" (950Mhz) working!

How did I check this worked? I installed nbench from http://www.tux.org/~mayer/linux/bmark.html and run ./bench in the unpacked catalog.

My values might have been kind of low because I run under Xwin. Got this:

=====================ORIGINAL BYTEMARK RESULTS=====================
INTEGER INDEX       : 15.668
FLOATING-POINT INDEX: 5.021
Baseline (MSDOS*)   : Pentium* 90, 256 KB L2-cache, ...
=========================LINUX DATA BELOW==========================
CPU                 :
L2 Cache            :
OS                  : Linux 3.2.27+
C compiler          : gcc version 4.6.3 (Debian 4.6.3-8+rpi1)
libc                : libc-2.13.so
MEMORY INDEX        : 3.442
INTEGER INDEX       : 4.302
FLOATING-POINT INDEX: 2.780
Baseline (LINUX)    : AMD K6/233*, 512 KB L2-cache, gcc 2.7.2.3, ..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.