I'm trying to start tightvncserver but I can't get the service name right

I tried

service tightvncserver start


service tightvnc start


service vncserver start

but all i get is unrecognized device. i tried service --status-all but the tightvnc is not listed.

  • just enter tightvncserver in terminal or on ssh
    – Milliways
    Jun 17 '14 at 0:52

If you want to run tightvncserver then in the command terminal you would type in vncserver. I believe you may have to specify the port as well.

To do that you type in :

vncserver :1

where 1 is the port that you are going to use. I just stick with the default on mine. Are you looking have vncserver start up on boot? If so you need to add in a script that will run the server on start up. If you don't you will have to start vncserver each time the pi is restarted. I will look for that script and add it onto this answer when I find it. Hopefully that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.