3

I bought the Raspberry Pi Model B (Raspberry Pi Ultimate Starter Kit off Amazon) thinking this would be my first and final purchase for a while, but have been unsuccessful in getting the computer running without a keyboard. I followed the endless tutorials online about a "headless setup" and want to avoid buying more if I don't have to, especially just starting out.

Here is what I did.

  1. I downloaded the zip file for Raspbian.

  2. I formatted my SD card using tutorial on elinux.org titled "On Mac OSX--Using system tools mostly graphical interface". There are some nice videos that I watched in tandem (Keith's Pi Tutorial).

  3. ATTEMPT 1 - Use the console cable (as suggested by the YouTube video cited above) and written down in the Adafruit tutorial (Lesson 5 on their site). Unfortunately, I got an error elaborated in this post, Using a Console Cable, Error "Could not find PTY", MAC.

Question for Attempt 1: Where is the /etc/inittab file elaborated in the post above and numerous online forums? Does this directory exist even if I haven't booted up and configured my Raspberry Pi? If it does exist, how do I access it?

  1. ATTEMPT 2 - I tried plugging in my Raspberry Pi to a router, but did not find its IP address. On the terminal, I used:

    arp -a

I got a list of IP addresses as shown in the picture of my terminal.

My Terminal

I then tried to SSH into the Pi using the command:

ssh pi@IPADDRESS

and each time got connection refused. Then I accessed my router by navigating to http://192.168.0.1/. However, still no new IP addresses was listed there. I then tried downloading the application "Pi Finder". But again, no luck. I then thought maybe the Wi-Fi USB accessory included in the kit might improve my chances. But it did not.

Question for Attempt 2: Where is the IP Address for my Pi? Again, am I experiencing difficulties since I haven't configured my Pi yet? Why is the IP address not showing up?

  • Does the Pi actually boot? You should see the green LED flickering and eventually after about 20 seconds the network LEDs should be lit (if you have an ethernet cable plugged in). /etc/inittab is on the ext4 (second) partition of the SD card. – joan Jun 16 '14 at 20:44
  • The Pi does boot. I see green LED flickering and then more lights turn on after I plug in the ethernet cable. – Charlie Jun 16 '14 at 20:48
  • How do I access the second partition? I have tried using the terminal and all I get is "boot". Specifically, \Volumes\boot – Charlie Jun 16 '14 at 20:50
  • 1
    on the Mac nmap -sP 192.168.0.* may help – Milliways Jun 17 '14 at 0:37
1

I've used an Ethernet cable connected directly to my PC. Just follow these steps:

  1. Burn/copy your std RPi img to SD card
  2. Connect your RPi to your PC using a ethernet cable.
  3. Start your RPi.
  4. When started, open a Terminal in your PC and issue: $ ssh pi@raspberrypi.local (password: raspberry). If raspberrypi.local doesn't work, try raspberrypi.
  5. Done.
1

I just wrote a blog post on how I managed to do it: Install Raspberry Pi headless on OS X. But your problem sounds to me like the system hasn't installed and or booted up correctly. For copying Raspbian on the SD card I used Pi Filler that formatted the card and copied the Raspbian img file onto the card.

I also had problems getting the right IP address as my DHCP was being contrary but Pi Finder did a good job of finding it.

  • 1
    It's great that you wrote a blog on this. However, whilst your link may answer the question, it would be preferable to include the essential parts of the linked here, and provide the link for citation. As such, this is a link only answer, and links tend to die over time, which will drastically reduce the usefulness of your answer. Please see the stack exchange policy on link only answers: meta.stackexchange.com/questions/225370/…. If you could edit your answer to include the relevant information, then that would be great. – Greenonline Mar 29 '16 at 11:13
  • Just a brief comment here from my end. Unzipping the latest iso images of raspbian when using a mac works well with The Unarchiver app ( wakaba.c3.cx/s/apps/unarchiver.html ) and then following the standard instructions with dd ... ( raspberrypi.org/documentation/installation/installing-images/… ). I am just mentioning this, because the default unzip utility that os x has does not work well for the decompression of the iso image and then even if the raspberry has lights blinking and appears to be booting, it is not really booting. – MightyMouse May 30 '16 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.