0

I just downloaded a fresh Raspbian image and I can't get the ethernet to work with it. The strange thing is that it works without problem on my OpenElec SD card.

I tried many things with the /etc/network/interfaces file and I even tried to plug a wifi usb dongle without success.

iwconfig:

lo    no wireless extensions
eth0  no wireless extension

ifconfig eth0:

eth0    Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
        UP BROADCAST MULTICAST MTU:1500 Metric:1
        RX packets:0 errors:0 dropped:0 overruns:0 frame:0
        TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
        collisions:0 txqueuelen:1000
        RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

with the /etc/network/interfaces :

auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet dhcp

I tried to switch the ethernet cable without success (even if both work with OpenElec).

It starts to turn me crazy and I think I will try with an Arch or a Pidora soon if I don't find a solution. But I'm more confortable with debian so that makes me a little bit sad :(

EDIT: Okay, network stopped working on my OpenElec install too. So I got a little angry, threw the Pi on the sofa and the network LEDs started blinking again. Everything works now. Conclusion of the story : if you don't understand why things don't work, try to break them, that'll fix them.

  • try removing the line allow-hotplug eth0 and line auto eth0. I don't think they are needed. – PhillyNJ Jun 19 '14 at 0:50
  • Doesn't change anything :/ – volent Jun 19 '14 at 6:01
2

I had this same problem some time ago.

Try:

auto lo
iface lo inet loopback

iface eth0 inet static
address 10.10.10.181 # Replace with your address
netmask 255.255.255.0 # Replace with your netmask
network 10.10.10.0 # Not really needed... If you want, set your network address
gateway 10.10.10.1 # Your gateway
dns-nameservers 8.8.8.8

iface default inet dhcp

That is my actual configuration.

If that works, it is likely that your Pi doesn't find a valid DHCP server in the network he is connected to.

Let me know if that helped :)

  • Welcome to the Pi exchange. Thanks for posting an answer but may I suggest you possibly describe how to work out if there is a DHCP or not as it would compliment the question and your answer. PS - You don't need to sign your answers - It is already signed with your name on the bottom. – Piotr Kula Jul 20 '14 at 10:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.