1

I read this topic here: Why won't my Raspberry Pi overclock?

but it seems a bit old to me and this line here

echo 60 > /sys/devices/system/cpu/cpufreq/ondemand/up_threshold

doesn't work because I dont have cpufreq inside /sys/devices/system/cpu. I also tried

echo 60 > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/up_threshold

but then I stop at missing ondemand folder in cpufreq.

Now my question stays the same as in that thread: Why does the Turbo not kick in? I did apt-get update apt-get upgrade and rpi-update many times so I guess I have the newest Raspbian on my RPi Model B.

The Turbo only works if I set

force_turbo=1

or

echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

which both always forces to stay in the overclocked state. I want to use my Pi 24/7 but only overclock when unter hard stress, like somebody playing on the Minecraft-server. The empty server idles a lot and could save the heat.

Any good solutions how I could set the threshold lower?

1

Okay, I solved this. Made 2 mistakes. It should look like this:

# Here I forgot the quotes
echo "ondemand" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

# This line should be AFTER the other one.
# If ondemand isn't set, you can't set it's threshold ;)
echo 95 > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/up_threshold

If the script stumbles over an error it just stops! So check everything twice, guys! :D

Interesting is that most tutorials tell that the default-governor is "ondemand" but for me it is "powersaving". That's why it was always taking the default or _min values.

Now it perfectly goes to the set _min value of 300 MHz in idle or low usage like a running Minecraft-server with no players on it. And jumps up to 1130 MHz when the performance is needed. It also feels smoother :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.