3

I run raspbmc on my Raspberry Pi (Model B rev 2) but enhanced it a little bit by installing mpd, denyhosts and tmux. I use it for watching movies (XBMC) and listening to music (mpd). All data are stored on NAS which is mounted via CIFS.

Unfortunately, my Pi stops working frequently in random moments and I have to do a hard reset. Any command in the console (which, surprisingly, is still working) gives Bus error message. I can't even check what's just happened because dmesg doesn't work either:

$ dmesg
-bash: dmesg: command not found
Bus error

When I log out I get also:

-bash: /home/username/.bash_logout: Input/output error

I tried to fsck the SD Card but since raspbmc switched to f2fs I couldn't find way to do it. I'm using GoodRAM SDHC 8GB Pro class 10.

There is quite a lot of free memory when the problem occurs, so I think the memory is not the reason.

I have no idea how to fix the problem. Where should I start?

  • Sounds like a faulty SD card. Is it well seated? Do the contacts look springy? – joan Jun 22 '14 at 19:39
  • @joan The card sits well, I pushed it several times to make sure. My previous card (same manufacturer and model) was broken because of bad blocks. I can't check this one because it uses f2fs. What's important, it boots and works good until it breaks after several hours, so I don't think it's a contacts issue. – Mikołaj Pastuszko Jun 25 '14 at 20:02
  • The only other obvious thing to check is the power-supply. If you have a meter you could check that there is 5V between Test Point 1 and Test Point 2 (TP1/TP2). – joan Jun 25 '14 at 20:08
2

I think I solved the problem by replacing the SD card with one from SandDisk. Raspberry has worked for several days without freeze. Seems like GoodRAM SDHC 8GB Pro class 10 didn't play well with Raspberry Pi.

I updated list of SD cards compatibile with Raspberry Pi accordingly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.