0

While I was following a Raspberry Pi VLC hardware acceleration tutorial in the compiling stage I have received this error:

configure: error: Package 'libavcodec' requires 'libavutil =
53.3.0' but version of libavutil is 51.22.2. 
Pass --disable-avcodec to ignore this error.

I have tried to install packages I found on debian via dpkg, and then I started to receive these messages

root@bahaa-pi:/home/bahaa/Desktop/lib# apt-get upgrade 
Reading package lists... Done 
Building dependency tree    
Reading state information... Done 
You might want to run 'apt-get -f install' to correct these. The following packages have unmet dependencies:  
    libavcodec-dev : Depends: libavcodec55 (<= 6:10.2-99) but it is not installable or
    libavcodec-extra-55 (<= 6:10.2-99) but it is not installable

    Depends: libavcodec55 (>= 6:10.2-1) but it is not installable or
             libavcodec-extra-55 (>= 6:10.2-1) but it is not installable
    Depends: libavutil-dev (= 6:10.2-1) but 6:0.8.10-1+rpi1 is installed

libavformat-dev : Depends: libavcodec-dev (= 6:0.8.10-1+rpi1) but 6:10.2-1 is installed 

E: Unmet dependencies. Try using -f. 

I've tried

root@bahaa-pi:/home/bahaa/Desktop/lib# apt-get install -f 
Reading package lists... Done 
Building dependency tree    
Reading state information... Done 
Correcting dependencies... failed. 
The following packages have unmet dependencies:  

libavcodec-dev : Depends: libavcodec55 (<= 6:10.2-99) but it is not installable or
    libavcodec-extra-55 (<= 6:10.2-99) but it is not installable
                  Depends: libavcodec55 (>= 6:10.2-1) but it is not installable or
                  libavcodec-extra-55 (>= 6:10.2-1) but it is not installable

Depends: libavutil-dev (= 6:10.2-1) but 6:0.8.10-1+rpi1 is installed 

libavformat-dev : Depends: libavcodec-dev (= 6:0.8.10-1+rpi1) but 6:10.2-1 is installed 

E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. 

E: Unable to correct dependencies

What ever I try to do with apt-get I receive the same error. Can anyone help me with this please?

  • 1
    Which distribution are you using? You MUST NOT use Debian packages with Raspbian. – joan Jun 30 '14 at 18:12
  • Agreed with joan. You can't use Debian packages on Raspbian, first off because they most likely won't be compatible (the packages you found on Debian probably coincide with your architecture - 32bit, 64bit - which won't match up to your Pi, which is ARM-based.) Second, even if you do manage to install packages from regular Debian on Raspbian, it may cause issues because of the fact that Raspbian, although based on Debian, is still a separate being and has its own software repositories. – RPiAwesomeness Jun 30 '14 at 18:51
  • i used .deb:armhf – Bahaa Zahika Jul 1 '14 at 0:25
  • Is that error is fixable ? – Bahaa Zahika Jul 1 '14 at 0:27
  • If it gets in the way of other dpkg installations, you could try apt-get purge on the packages flagged as having unmet dependencies – Beta Decay Aug 3 '14 at 10:29
1

AFAIK there is no version of VLC which uses the GPU.

Use omxplayer which is already installed on the Pi and performs much better, because it uses the GPU. It is actually the core of the RASPBMC Media Centre.

NOTE omxplayer runs from the command line.

  • I saw it in other post after it was to late – Bahaa Zahika Jul 1 '14 at 0:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.