0

my problem is, that I do not have screen and keyboard on raspberry. And I am trying to connect to it via SSH. But from default is in sshd_config set: PubkeyAuthentication to yes. And that is my problem, because when I copy .img file to SD card I`m unable to login via ssh because of pubkeyauthentication. How can I change it to no using my PC? (Ubuntu) I tried to mount .img file and edit sshd_config, but I am able to mount it only read-only. What do u suggest?

  • Have you attempted editing the sshd_config file as sudo? – RPiAwesomeness Jun 30 '14 at 21:30
  • You should be able to mount the SD card on Ubuntu. – Milliways Jun 30 '14 at 23:57
1

Do you want to login with a password? Then I think it's the PasswordAuthentication option you want to check. It doesn't matter if PubkeyAuthentication is yes as well, they can both be yes. Add the -v option to get debug info during connection setup: ssh -v user@rpi

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.