0

I followed the same steps in this Adafruit Wi-Fi Setup but I am not Getting Connection in Pi

This is output during lsusb and iwlist scan

 pi@raspberrypi ~ $ lsusb
    Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. 
    Bus 001 Device 004: ID 0846:9041 NetGear, Inc. WNA1000M 802.11bgn [Realtek RTL8188CUS]
    pi@raspberrypi ~ $ iwlist scan
    wlan0     Scan completed :
              Cell 01 - Address: 70:62:B8:BB:FE:8D
                        ESSID:"NANDI"
                        Protocol:IEEE 802.11bgn
                        Mode:Master
                        Frequency:2.412 GHz (Channel 1)
                        Encryption key:on
                        Bit Rates:300 Mb/s
                        Extra:wpa_ie=dd1a0050f20101000050f20202000050f2020050f20401000050f202
                        IE: WPA Version 1
                            Group Cipher : TKIP
                            Pairwise Ciphers (2) : TKIP CCMP
                            Authentication Suites (1) : PSK
                        IE: Unknown: DD7C0050F204104A0001101044000102103B00010310470010630412531019200612287062B8BBFE8D10210006442D4C696E6B1023000752544C383637311024000D45562D323030362D30372D32371042000C3730363262386262666538341054000800060050F20400011011000944534C2D3237353055100800020086
                        Quality=0/100  Signal level=100/100  

    lo        Interface doesn't support scanning.

    eth0      Interface doesn't support scanning.

enter image description here

This is /etc/network/interfaces

auto lo
 iface lo inet loopback
 iface eth0 inet dhcp

 allow-hotplug wlan0
auto wlan0

 iface wlan0 inet dhcp
        wpa-ssid "SSID"
        wpa-psk "PASSWORD"

And Also I tried Like this Post wifi setup for multiple networks 2nd answer i.e USER ppumkin's answer

It is showing the Wi-fi Connection when I

sudo wicd-curses 

Even I Configured the Same Way, but When I click "C" it is disconnecting From LAN As Specified By [USER]ppumkin, but It is not Connecting to Wi-Fi. enter image description here

I am Checking it with a webserver.. I've Installed Apache In Pi. Using Wired Network I will Get Index.Html but with Wi-Fi I am Not Getting the Index Page

  • What does dmesg report for the wifi dongle? The contents of /etc/network/interfaces would probably be useful. – joan Jul 6 '14 at 11:31
  • @joan I have added the /etc/network/interface... I've Removed My SSID and Password – user40138 Jul 6 '14 at 11:42
  • See what dmesg says when the dongle is plugged in. So remove the dongle, wait a couple of seconds, reinsert the dongle. Have a look at the last few lines of the dmesg command output. What does it have to say about the dongle? – joan Jul 6 '14 at 11:46
1

I think that, like most of us, you have ended up with a confused set of configuration statements. I expect you've fixed it by now, but others may find this useful. This assumes a modern WPA2 setup.

/etc/wpa_supplicant/wpa_supplicant.conf should be:

ctrl_interface=DIR=/var/run/wpa_supplicant
GROUP=netdev
update_config=1
network={
    ssid="myWifiNetworkName"
    psk="myWifiPassword"
    proto=RSN
    key_mgmt=WPA-PSK
    pairwise=CCMP
    auth_alg=OPEN
}

For an older system proto could be WPA and pairwise could be TKIP. Then in /etc/network/interfaces

auto lo
iface lo inet loopback
iface eth0 inet dhcp
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.