3

I've connected my nexus 4 to one of the usb ports on the model b, but it fails to mount the internal storage in /media. How do I get access to the internal storage?

Connected as Media device (MTP), but same results on Camera (PTP).

dmesg's console out

[ 8482.187552] usb 1-1.2: new high-speed USB device number 15 using dwc_otg 
[ 8482.289440] usb 1-1.2: New USB device found, idVendor=18d1, idProduct=4ee2 
[ 8482.289479] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3 
[ 8482.289498] usb 1-1.2: Product: Nexus 4 [ 8482.289515] usb 1-1.2: Manufacturer: LGE 
[ 8482.289532] usb 1-1.2: SerialNumber: 0xxxxxxxxxxx7
1

On my Arch Linux laptop I use go-mtpfs for that. In AUR there is a git version. Then it is simple: go-mtpfs <mountpoint> and you have access to anything.

You can try to compile from git directly from here.

Raw mtpfs never worked for me.

1

I attempted to go through go-mtpfs, but had trouble building it. I got stuck at trying to install the libusb package.

After this, I tried just plain mtpfs and it worked. I followed the instructions from this link And used a script instead of the bashrc commands.

!/bin/bash
if mountpoint -q /media/MTPDevice; then
    fusermount -u /media/MTPDevice
else
    mtpfs -o allow_other /media/MTPDevice
fi
0

I used to use gphotofs on arch. Mounting via gphotofs /mount_point and umounting with fusermount -u /mount_point.

(However now I encounter some problems with this tool and can't recall how I've fixed it in past)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.