1

I installed Processing 2.2.1 (linux) on the RasPi (running Debian Wheezy) to connect a USB-Webcam and capture video stream with the standart processing.video* library. When I try to run the program (from processing window or exported) I get the following error:

NoClassDefFoundError: Could not initialize class com.sun.jna.Native

After searching the web for several days I found and tried following solutions, wich did not change anything:

  • Install gStreamer 0.10 package (as seen here)

  • Update to the latest Java Version which is:
    java version "1.8.0-ea"
    Java(TM) SE Runtime Environment (build 1.8.0-ea-b108)
    Java HotSpot(TM) Client VM (build 25.0-b50, mixed mode)

  • install JNA 4.0.0 (reference here)

after it still resulting in the same error, I am not really shure what to try next since I am also more or less a beginner when it comes to the RaspberryPi and Java.

Any Tips/Hints are highly appreciated!

  • Don't use a USB camera and don't use Java on a rpi. – hendry Jul 10 '14 at 21:18
  • Yeah I can imagine some other combinations that should work much better, but the problem is I am not familar with python neither with C++. This is part of a project in university, so I also have not much time to get into that other stuff, and with a solution to that error I think it would work fine for my needs.. – ibanes88 Jul 13 '14 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.