5

NTPD appears to run successfully and poll the time server, however it doesn't actually set the time.

# ntpd -d &
ntp engine ready
reply from 83.170.75.28: offset 1348642593.061240 delay 0.035977, next query 9s

# date
Thu Jan 1 10:53:29 BST 1970

This is using the latest hf Arch Arm kernel.

closed as off-topic by Jivings Jan 28 '15 at 10:55

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be specific to the Raspberry Pi within the scope defined in the help center." – Jivings
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    What is the question? – Christian Sep 26 '12 at 19:34
  • @Christian You can't work it out because I haven't used a question mark? – Jivings Sep 26 '12 at 20:21
  • I thought it as a statement that, NTPD is not actually setting the time. That's a statement. But why it's not, is the question :P – Christian Sep 27 '12 at 12:32
  • Related: Why isn't NTPd updating local time? – Tobias Kienzler Dec 13 '12 at 16:47
11

Quoting from ntpd documentation:

In case there is no TOY chip or for some reason its time is more than 1000s from the server time, ntpd assumes something must be terribly wrong and the only reliable action is for the operator to intervene and set the clock by hand.

Again, quoting from the ntpd man page:

-s Set the time immediately at startup if the local clock is off by more than 180 seconds. Allows for a large time correction, eliminating the need to run rdate(8) before starting.

So a ntpd -s in a terminal should be sufficient to fix the problem and let ntpd adjust the time normally from there on.

UPDATE: now it should be ntpd -g

  • See also: ntpdate. – XTL Oct 3 '12 at 7:14
  • I've come here after suffering the same problem. I find that with ntpd version 4.2.6p5 the -s option does something different to what is described above (it specifies Statistics file location). I think the equivalent option is -g but this had no effect for me (it is used without effect by the default sysemd unit). What worked for me was to execute ntpd uk.pool.ntp.org prior to starting ntpd. To do this I added ExecStartPre=/usr/bin/ntpdate uk.pool.ntp.org to the systemd unit file. – starfry Apr 24 '13 at 14:22
  • 1
    updating the above comment, ntpdate is deprecated. I am now using ntpd -gq. – starfry Apr 25 '13 at 11:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.