3

Immediately after install, I've overclocked my raspberry (1 GHz). After power failure today (the whole building) I can't overclock it again. First I tried:

sudo raspi-config

Then I tried to make the same as root - without success. I don't want to use the force_turbo=1 flag. My /boot/config.txt looks as follow:

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
arm_freq=1000

# for more options see http://elinux.org/RPi_config.txt
core_freq=500
sdram_freq=500
over_voltage=6

The output from cat /proc/cpuinfo:

pi@raspberrypi:~$ cat /proc/cpuinfo 
Processor   : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS    : 697.95

and before today's power failure was:

pi@raspberrypi:~$ cat /proc/cpuinfo 
Processor   : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS    : 996.14

So....I can reinstall, that isn't problem. But I want to know what caused this problem.

  • Did you reboot after reconfiguring? Have you upgraded the firmware? – Alex Chamberlain Oct 8 '12 at 17:35
  • yes, twice.....after using ''suro raspi-config'' and after ''raspi-config'' as root. – cupakob Oct 8 '12 at 17:37
7

It seems to me that you updated from all firmware, which only supported static ARM frequency to newer one, which supports dynamic frequency change using cpufreq infrastructure. You can read about this change in my answer to the question Why won't my Raspberry Pi overclock?

You can also quite easily check this, just type:

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq

You should get your current frequency, which would be 700000 (700MHz) on idle system.

Now make some load - open up a big WWW site in the browser or make some computations and check again, this time you should get 1000000 (1GHz).

You can change this behavior and it is also described the answer I pointed out earlier.

  • okay, now i understand, what is happend...I thought, i'm using dynamic frequency for the cpu. You are right - scaling_cur_freq give me as output the 1000000. Thanks a lot. – cupakob Oct 9 '12 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.