I am trying to use the current soft-float Debian release from the download page 2012-08-08-wheezy-armel. I can't get it to boot. There are a couple of brief flashes from the OK LED and the the red power LED is lit, the Raspberry Pi logo appears on the screen but nothing else. I have tried:

Re-downloading image and checking SHA1 checksum

Writing image on two different windows machines with two different card readers

Three different SD cards

Two different RPi boards

The beta wheezy image boots fine as do the Raspbian and Arch images. I'm using the recomended RS 1.2A power supply, keyboard, mouse and HDMI monitor only attached.

Any ideas?


Edit: Here's the layout on the partition visible on Windows. Anything wrong with it?

    Volume in drive D has no label.
 Volume Serial Number is D5C1-EF53

 Directory of D:\

08/08/2012  17:06         2,018,480 arm128_start.elf
08/08/2012  17:06         2,018,480 arm192_start.elf
08/08/2012  17:06         2,018,480 arm224_start.elf
08/08/2012  17:06           630,768 arm240_start.elf
08/08/2012  17:06            16,536 bootcode.bin
08/08/2012  22:53               142 cmdline.txt
08/08/2012  22:53             1,180 config.txt
08/08/2012  17:06         6,231,036 kernel.img
08/08/2012  17:06         4,115,364 kernel_cutdown.img
08/08/2012  17:06        16,256,148 kernel_emergency.img
08/08/2012  17:06           275,235 loader.bin
08/08/2012  17:06         2,018,480 start.elf
09/08/2012  00:02               137 issue.txt
              13 File(s)     35,600,466 bytes
               0 Dir(s)      22,994,944 bytes free
  • Have you tried using the cmdline.txt and config.txt from the other images? Commented Oct 9, 2012 at 4:33
  • It may be some bug in older kernel that prevents you from booting. You could try copying all the firmware files from SD card with Raspian or other distribution that works fine to your card with wheezy-armel. You should copy config.txt, cmdline.txt, kernel.img, loader.bin, start.elf and bootcode.bin. Commented Oct 9, 2012 at 8:58
  • Thank you Haskeller and Krzysztof. I will try these suggestions ASAP.
    – Guy
    Commented Oct 9, 2012 at 11:30
  • Have you tried to upgrade the firmware with any of the working distros?
    – Christian
    Commented Oct 9, 2012 at 13:24
  • Success! I tried copying just cmdline.txt and config.txt from a raspbian image and that made no difference. Then I copied over kernel.img, loader.bin, start.elf and bootcode.bin and I was able to boot. My questions now are: Do I need other files from the raspbian image to make my soft-float image complete e.g. kernel_emergency.img ? How come I am seeing this problem and no-one else seems to? Christian: Sorry, I don't understand what you mean - upgrade the firmware with a working distro???
    – Guy
    Commented Oct 9, 2012 at 23:58

1 Answer 1


By a process of elimination I found that it was start.elf that was stopping the soft-float Wheezy image from booting. I copied one of the other memory split files to start.elf and can now boot the image.

  • Unusual error. Any idea why?
    – Jivings
    Commented Oct 14, 2012 at 22:34
  • No. It consistently does it, tried on many different downloaded images and hardware combinations. I can only guess that start.elf in the official image is corrupt in some way and that it has remained unreported/unfixed because very few people use the soft-float version and those that do use one of the other memory split elf files from the beginning.
    – Guy
    Commented Oct 15, 2012 at 9:54
  • I've got the exact same problem as you, but mine only happens when I boot on an older RPi board (delivered around june). Running soft float wheezy on my two more recent boards (delivered september) works fine. I will try your solution of copying the start.elf from a working image. Commented Oct 16, 2012 at 2:22
  • Success! Copying the start.elf from a working (hard float) debian wheezy image allows my soft float wheezy to work on the older board, as well as still working on the new board. Thanks a million. Commented Oct 16, 2012 at 7:12
  • @dodgy_coder: Interesting. All my boards are "old", delivered before September. I wonder if some subtle hardware change is at the root of this.
    – Guy
    Commented Oct 16, 2012 at 9:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.