0

I have installed the xbmc image on my raspberry pi, which uses dropbear in order to provide ssh connectivity. The raspberry pi receives a local and fixed ip from my dhcp server (192.168.1.102).

After some time, I am no longer able to connect to my raspberry pi via ssh, albeit I am able to ping it. In addition, it has internet connectivity, since I am able to up and download files to it.

Anybody has faced the same behaviour? Is there any possibility to find something in the logs in order to identify the causing problem?

Edit In the syslog file I found just the following line about ssh or dropbear:

Jul 12 14:31:05 raspbmc xinetd[1655]: Reading included configuration file: /etc/xinetd.d/ssh [file=/etc/xinetd.d/ssh] [line=12]

cat /etc/xinetd.d/ssh gives the standard configuration:

service ssh { disable = no socket_type = stream wait = no user = root protocol = tcp server = /usr/sbin/dropbear server_args = -i flags = IPv6 }

Unfortunately, journalctl or systemctl status are not installed.

  • And what does it tell you the SSH when you use verbose flag? E.g.: ssh -v user@host – kotrfa Jul 13 '14 at 16:08
  • At the moment, I am not able to reproduce the error. If I can encounter the problem again, I will post the output of the above command. – DrRobotto Jul 15 '14 at 11:03
1

This looks like that problem is only on SSH client - since it's the only service which is not responding.

So look for logs of SSH and try to restart it. There is also verbose flag when you are trying to connect using SSH - it should give you information in which part SSH login failed (you haven't supply a lot of information like error messages etc...).

If you are using systemd as a daemon manager it's really easy to track log files with journalctl or systemctl status <unit>.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.