2

A few months ago I created a project that uses the python-tesseract library on the raspberry pi. Since then I reinstalled rasbpian, and now I would like to reinstall the python-tesseract libary. The problem I'm having is that the library doesn't install anymore on the raspberry pi. The raspberry-pi was never officially supported, but it could be installed. The installition process I used a few months ago, doesn't work anymore and I tried everything I could find but nothing worked. Did anyone lately install python-tesseract on the pi? If yes, how?

python 2.7

Raspbian fully up-to-date (including firmware)

  • what exactly have you tried and what error(s) have you got? – lenik Jul 14 '14 at 5:19
2

So after some searching and trying everything that I could come up with, I have found a way that works. This commands below work, but it is still a little raw, a lot of the installed dependencies are unnecessary. The 0.7.4 version that is used is not on the official website so it took some time to find it. But I hope some I help some people with the same problem!

sudo apt-get install python-distutils-extra tesseract-ocr tesseract-ocr-eng libopencv-dev libtesseract-dev libleptonica-dev python-all-dev swig libcv-dev python-opencv python-numpy python-setuptools build-essential subversion

sudo apt-get install tesseract-ocr-eng tesseract-ocr-dev libleptonica-dev python-all-dev swig libcv-dev

sudo svn checkout http://python-tesseract.googlecode.com/svn/python-tesseract-0.7.4/

sudo python setup.py build
sudo python setup.py install

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.