4

I got my RPi a few days ago and I feel rather useless. This is for the very simple reason that I have yet to even be able to ssh into my pi. In other words, I have not logged into it, and I have not accessed it. I am trying to remotely connect to my Pi through my wireless laptop with an RJ-45 Ethernet Cable. I'm currently running Ubuntu 14.04 LTS and my pi is using Raspbian. The SD card I'm using is 8 GB. Whenever I attempt to ping it using nmap, it doesn't show up. (Also, I'm using a Model B Pi.) Any help would be appreciated., thanks. -Omega Emrys

PS: I know what the search bar is, don't tell me to use it please.

I finally found my pi's ip, except I'm not sure it's the right ip. Here is my ifconfig:

eth0 Link 
encap:Ethernet 
HWaddr 14:da:e9:51:d5:06
inet addr:169.254.8.18 
Bcast:169.254.255.255 Mask:255.255.0.0
inet6 addr: fe80::16da:e9ff:fe51:d506/64 
Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:28 errors:0 dropped:0 overruns:0 frame:0
TX packets:2976 errors:0 dropped:0 overruns:0 carrier:19
collisions:0 txqueuelen:1000
RX bytes:9576 (9.5 KB) TX bytes:348018 (348.0 KB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:17547 errors:0 dropped:0 overruns:0 frame:0
TX packets:17547 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1701463 (1.7 MB) TX bytes:1701463 (1.7 MB)

wlan0 Link encap:Ethernet HWaddr 40:25:c2:51:3c:a4
inet addr:192.168.1.41 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::4225:c2ff:fe51:3ca4/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:719321 errors:0 dropped:0 overruns:0 frame:0
TX packets:377846 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1041273963 (1.0 GB) TX bytes:32401705 (32.4 MB)

wmx0 Link encap:Ethernet HWaddr 64:d4:da:5c:fc:92
UP NOARP MTU:1400 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:20
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

When I disconnect the Ethernet cable, the inet address at the very top disappears. However, when I try to nmap -sn the ip, it doesn't refer to the host as raspberry pi. Also, I do manage to ssh into it but when it ask me for the password and I enter "raspberry", it denies me permission, any help you could give me would be wonderful. Thank you very much, Omega.

(EDIT: It just changed the inet address to 10.42.0.1 after I unplugged and plugged the Ethernet a couple of times, which I'm guessing suggest that it is dhcp?)

(EDIT: I did as was suggested by Wilf, and this is what I got:

Nmap scan report for 10.42.0.1
Host is up (0.00012s latency).
Not shown: 998 closed ports
PORT   STATE SERVICE VERSION
22/tcp open  ssh     (protocol 2.0)
| ssh-hostkey: 1024 25:d9:6c:8c:0c:3b:b6:3e:be:a7:f6:cc:9b:6b:87:70 (DSA)
| 2048 96:a3:fe:bc:27:c8:79:45:b5:a0:a1:d7:d0:1f:97:35 (RSA)
|_256 0d:77:5a:d0:6b:ae:04:00:6a:68:1a:17:b5:57:9f:31 (ECDSA)
53/tcp open  domain  dnsmasq 2.68
| dns-nsid: 
|_  bind.version: dnsmasq-2.68
1 service unrecognized despite returning data. If you know the service/version, please submit the following fingerprint at http://www.insecure.org/cgi-bin/servicefp-submit.cgi :
SF-Port22-TCP:V=6.40%I=7%D=7/20%Time=53CBCF84%P=x86_64-pc-linux-gnu%r(NULL
SF:,29,"SSH-2\.0-OpenSSH_6\.6\.1p1\x20Ubuntu-2ubuntu2\r\n");
No exact OS matches for host 
TCP/IP fingerprint:
OS:SCAN(V=6.40%E=4%D=7/20%OT=22%CT=1%CU=43809%PV=Y%DS=0%DC=L%G=Y%TM=53CBCF9
OS:3%P=x86_64-pc-linux-gnu)SEQ(SP=104%GCD=1%ISR=109%TI=Z%CI=I%TS=8)SEQ(SP=1
OS:04%GCD=1%ISR=109%TI=Z%CI=I%II=I%TS=8)OPS(O1=MFFD7ST11NW7%O2=MFFD7ST11NW7
OS:%O3=MFFD7NNT11NW7%O4=MFFD7ST11NW7%O5=MFFD7ST11NW7%O6=MFFD7ST11)WIN(W1=AA
OS:AA%W2=AAAA%W3=AAAA%W4=AAAA%W5=AAAA%W6=AAAA)ECN(R=Y%DF=Y%T=40%W=AAAA%O=MF
OS:FD7NNSNW7%CC=Y%Q=)T1(R=Y%DF=Y%T=40%S=O%A=S+%F=AS%RD=0%Q=)T2(R=N)T3(R=N)T
OS:4(R=Y%DF=Y%T=40%W=0%S=A%A=Z%F=R%O=%RD=0%Q=)T5(R=Y%DF=Y%T=40%W=0%S=Z%A=S+
OS:%F=AR%O=%RD=0%Q=)T6(R=Y%DF=Y%T=40%W=0%S=A%A=Z%F=R%O=%RD=0%Q=)T7(R=Y%DF=Y
OS:%T=40%W=0%S=Z%A=S+%F=AR%O=%RD=0%Q=)U1(R=Y%DF=N%T=40%IPL=164%UN=0%RIPL=G%
OS:RID=G%RIPCK=G%RUCK=G%RUD=G)IE(R=Y%DFI=N%T=40%CD=S)

Network Distance: 0 hops

OS and Service detection performed. 
Nmap done: 1 IP address (1 host up) scanned in 23.92 seconds)

re (EDIT: Yes, the lights are lit up. FDK is Green LNK is Green, and 100 is yellow. ACT is the only one not lit up at the moment.)

(EDIT: Device Hardware Address: 14:DA:E9:51:D5:06)

  • How did you installed your pi ? Did you follow a guide such as this one ? – superbob Jul 17 '14 at 14:45
  • I was going to ask if you'd turned on ssh - but your penultimate paragraph sounds like it. Are you running ssh pi@10.42.0.1 (or whatever the ip is now...) – Daniel Jul 17 '14 at 14:52
  • @Daniel I am, but when it asks for the password, I enter raspberry and it denies me the access. – Omega Emrys Jul 17 '14 at 14:58
  • Precisely, what text does it print asking for the password? – joan Jul 17 '14 at 17:04
  • @joan $ ssh pi@10.42.0.1 ---> pi@10.42.0.1's password: – Omega Emrys Jul 17 '14 at 20:09
1

How I did a headless setup on a Mac.

  1. Downloaded etcher.

  2. Downloaded zip file of raspbian (you are using Ubuntu, not sure if it will work this way)

  3. Plugged in my SD card and burned the zip file to the SD card with etcher.

  4. Add a empty file called ssh, make sure there is no extension such as .txt

  5. Insert SD card into pi, connect Ethernet cable and micro USB cable.

  6. power up the pi, and find your pis IP address on your router page.

  7. Open terminal and type: ssh pi@YourIpaddress

  8. Change YourIpaddress in the last step to your raspberry pis up address

  9. Your done!

Hope this helps :)

0

Try this:

  1. Do a fresh install with a latest image of Raspbian OS using Etcher.

  2. Go to Raspberry Pi Configuration and enable SSH in Interfaces tab.

  3. Reboot the Pi.

  4. Connect the Pi and the computer/laptop to use in remote in the same network.

  5. Check your ip via executing ifconfig in terminal.

  6. If your using Ubuntu/Manjaro?Linux Mint, open terminal and execute ssh pi@xxx.xxx.xxx.xxx where xxx.xxx.xxx.xxx is the ip of the pi.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.