7

I have already configured by Raspberry Pi to be a wireless access point using the tutorial here: http://www.daveconroy.com/turn-your-raspberry-pi-into-a-wifi-hotspot-with-edimax-nano-usb-ew-7811un-rtl8188cus-chipset/ I used the Edimax Nano USB EW-7811Un (RTL8188CUS chipset) just as the tutorial did. The tutorial worked fine, and the Raspberry Pi was generating a wifi network by bridging to its ethernet connection. However, I would really like to have the Raspberry Pi be a hotspot for 5 Ghz wifi.

So I purchased the TL-WDN3200 wifi dongle which supports dual band wifi. According to this - http://elinux.org/RPi_USB_Wi-Fi_Adapters - the TL-WDN3200 uses the RT5572 chipset, and there is a "native driver available in Kernel 3.10.36+ (rt2800usb)".

Using uname -a gives me Linux raspberrypi 3.12.22+ #691 PREEMPT Wed Jun 18 18:29:58 BST 2014 armv61 GNU/Linux so I assume that my Kernel version should have a native driver. Indeed, when I type lsmod there is a rt2800usb module listed. Furthermore, when I use lsusb the wifi dongle is recognized : Bus 001 Device 005: ID 148f:5572 Ralink Technology, Corp.

The only problem right now that stops the wifi dongle from working is that hostapd refuses to start up. Here is my hostapd.conf file:

interface=wlan0
driver=rtl871xdrv
bridge=br0
ssid=test
channel=1
wmm_enabled=0
wpa=1
wpa_passphrase=testtest
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
auth_algs=1
macaddr_acl=0

The only thing I could think of is changing the driver to nl80211, but the driver is not recognized by hostapd. I even tried following the instructions to build hostapd from the online documentation but that didn't make hostapd recognize the nl80211 driver.

Is there anything I am missing here? If not, I was wondering whether anyone could recommend a 5Ghz wifi dongle that works out of the box for the Raspberry Pi? Thank you!

9
  • I think there are packages or binaries you can download with latest drivers. You should search around for it.
    – Piotr Kula
    Jul 18, 2014 at 18:38
  • I have been searching around for quite a while - nothing online seems to work. I seriously think this is a hostapd issue because I tried configuring the /etc/network/interfaces file to connect to a local network on my router and that works fine - its only when I use hostapd to try to make a wireless hotspot that the dongle doesn't seem to work. Jul 18, 2014 at 20:51
  • Ahhh. Are you sure it supports the hotspot feature. I forgot the technical term. Not all WiFi chips can change to be an AP. Maybe that's the problem.
    – Piotr Kula
    Jul 18, 2014 at 20:58
  • I'm not sure - do you know how I can check? I've been searching around but I haven't had much success - I did find this page though : wikidevi.com/wiki/Ralink_RT5572 Jul 18, 2014 at 21:14
  • 2
    Thanks for the help! I think I was using a different hostapd build since I was previously using the Edimax wireless dongle. I actually just tried a fresh install of Raspbian and hostapd and it worked! Jul 19, 2014 at 0:32

1 Answer 1

8

Problem Solved. I needed to do I fresh install of hostapd by first using sudo apt-get purge hostapd, then running which hostapd to see if I still had any remaining installations of hostapd - which I did. So after removing all hostapd installations, I just did a fresh install, configured it again with the nl80211 driver and everything worked out.

3
  • 2
    Great news :) I think you should be able to mark your answer as accepted. Hope to hear from you soon, either question or answers are always welcome! Good Luck
    – Piotr Kula
    Jul 20, 2014 at 19:18
  • awesome. Did you use the same hostapd.conf? I got it to work at 5ghz but with a specific changing of the hostapd.conf hw_mode=a channel=40 Feb 23, 2016 at 17:40
  • I just worked through this problem with the Ralink 5572, and posted the results in this question <raspberrypi.stackexchange.com/questions/42570/…>
    – tim11g
    Dec 31, 2016 at 17:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.