What if this solution: Cannot access the console in Raspbmc

does not work? I hit exit and then no blue screen appears. I keep pressing esc periodically and nothing happens, until I get the XBMC GUI again.

Is there any other way of getting to the console?

I want to fix the non-working ssh.

up vote -2 down vote accepted
  1. With Raspbmc running go to “Settings > System > Input Devices > Peripherals”, open “CEC Adapter” and uncheck the box that says “Enabled” then click “OK”.
  2. Go back to the home screen and click the standby icon and select “Exit”, this will bring up a blue splash screen which says “Press ESC for command line”. Press the Esc key now or the Raspberry Pi will just reboot.
  3. You will then be prompted to enter the username, (default = pi), and the password, (default = raspberry). Note that the password won’t be shown on screen as you type.
  4. The first time you use the command line you will be presented with “Package Configuration”, follow the onscreen instructions to set this up. The options I used were:
    1. Configuring locales: en_GB UTF-8 UTF-8
    2. Configuring tzdata: Europe > London
  5. You will be presented with the line All Set up now! Thanks for using Raspbmc. The command line is now ready to use.
  6. To exit back into xbmc just type exit and wait for it to jump you back into the XBMC GUI.

Source : http://blog.amitparekh.com/?p=19

  • 1
    Welcome to Raspberry Pi! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Steve Robillard Jul 22 '14 at 16:45
  • Thanks. The CEC adapter disabling from the peripherals was the solution! Well partially... I got the prompt, but the GUI was coming back automatically after a few seconds. So I had to type in quickly 'service xbmc stop' to prevent that and get the normal prompt... Then, just for the history, i just installed openssh-server and ssh service was brought back. – athanassis Jul 22 '14 at 18:27

this worked for me:

  1. With Raspbmc running go to “Settings > System > Input Devices > Peripherals”, open “CEC Adapter” and uncheck the box that says “Enabled” then click “OK”.

  2. Go back to the home screen and click the standby icon and select “Exit”, this will bring up a blue splash screen which says “Press ESC for command line”. Press the Esc key now or the Raspberry Pi will just reboot.

You can SSH into your Pi and execute commands that way. Which a tutorial can be found here

But I found a forum post that said you must exit Raspbmc and then hit escape! This trick me a while back but hopefully one of these solutions work!

Cheers!

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.