4

Crashes in quotes because I'm not really sure that you can call it a crash. I don't know how to figure out what exactly is happening.

The Problem

I've been trying to get my camera to work properly and have had some minor victories, but it's obviously not working the way it should be. I can take a picture and it will have some green banding across it, but trying to take a 10 second video clip shuts the pi off with just one red light on. I have to unplug it and plug it back in to regain access through ssh. When the video starts recording, you can see the camera sucking a lot of power because the LED's start to dim slightly. Then suddenly all but one red LED will go off. Most of the time the camera will finish filming the video and save it, but the video will have green banding and be choppy. After this, the pi will just sit there. I can't do anything through SSH until I unplug it and plug it back in.

Things to Note

I'm using this cell phone charger. As you can see, it's a 5V, 2.1A charger, so to the best of my knowledge, it should have no problem powering this setup.

I also have nothing else running, this is a fresh install of Raspbian and I'm literally just trying to take a video right now.

What I've Tried

  • Updating the firmware
  • Setting current_limit_override=0x5A000020
  • Overclocking all the way to TURBO
  • Lowering the bitrate on the video all the way down to 1000000bps
  • Increasing GPU Memory Split to 256

Any help is greatly appreciated!

  • 3
    Have you actually tested the voltage at the test points? See elinux.org/R-Pi_Troubleshooting#Troubleshooting_power_problems for details. – Steve Robillard Jul 22 '14 at 21:40
  • @SteveRobillard Alright I went ahead and took the levels and the supply was dropping below 4V when I was capturing video. So that's definitely what it is. I had no idea these chargers were so pathetic. With nothing running, several of them were putting out ~4.28V. Thanks for the help! I think I've found my answer, I need a new charger that will actually output 5V. – Willem Ellis Jul 23 '14 at 0:25
  • 2
    Glad I could help. Why don't you answer your own question and I will upvote your answer. It may help someone who has the same problem. – Steve Robillard Jul 23 '14 at 0:51
5

Per @SteveRobillard's suggestion, I tested the voltage of the Pi (http://elinux.org/R-Pi_Troubleshooting#Troubleshooting_power_problems). I found that the PSU's I was using (I tried various phone chargers) were only supplying ~4.28V when the Pi was just idle. When I took a picture it would drop to ~4V and a video would send it well below 4V. I believe the reason for my problem is because the PSU's aren't supplying enough power to the Pi. I'll likely order this one from Adafruit specifically designed to supply 5V at max current.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.