2

I have the following problem on ArchLinux system. My raspberry Pi won't boot unless I have my USB stick connected. I've been doing some tests and I discovered it is fstab related. When I comment the line that mounts my device it boots correctly without it.

Here's my fstab file:

# 
# /etc/fstab: static file system information
#
# <file system> <dir>   <type>  <options>   <dump>  <pass>
/dev/mmcblk0p1  /boot           vfat    defaults        0       0
/dev/sda1       /mnt/usbstick   vfat    uid=1000,gid=1000,utf8,dmask=027,fmask=137,users 0  0

I ask this question because I used this fstab entry without really understanding it (when I written my own fstab like in tutorials it never worked, I found this line somewhere, tryed and it worked fine). So if someone could help me understand it I would be very gratefull.

2

Adding nofail option solved the issue. It turned out it couldn't perform mount because of lack of the device, nofail optiom made it ignore it.

This post helped me finding the solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.