6

I have ZTE MF669 USB modem.

root@raspberrypi:/home/pi# lsusb

Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 0bda:8179 Realtek Semiconductor Corp.
Bus 001 Device 005: ID 19d2:0154 ZTE WCDMA Technologies MSM

I've read, that that my modem must be switched from mass storage mode to modem mode.

I have new Raspbian (downloaded 1 week ago), it has kernel 3.12.22+.

I have usb_modeswitch installed today from Raspbian repository (current version?).

When I run usb_modeswitch manually:

root@raspberrypi:/home/pi# usb_modeswitch -v 19d2 -p 0154 -V 19d2 -P 0117 -M "5553424312345678000000000000061b000000020000000000000000000000"

(these parameters can be found on many many sites by googling "modeswitch 19d2:0154")

it returns:

Looking for target devices ...
 No devices in target mode or class found
Looking for default devices ...
   found matching product ID
   adding device
 Found device in default mode, class or configuration (1)
Accessing device 005 on bus 001 ...
Getting the current device configuration ...
 OK, got current device configuration (1)
Using first interface: 0x00
Using endpoints 0x01 (out) and 0x81 (in)
Inquiring device details; driver will be detached ...
Looking for active driver ...
 No driver found. Either detached before or never attached

SCSI inquiry data (for identification)
-------------------------
  Vendor String: ZTE
   Model String: USB SCSI CD-ROM
Revision String: 2.31
-------------------------

USB description data (for identification)
-------------------------
Manufacturer: ZTE,Incorporated
     Product: ZTE WCDMA Technologies MSM
  Serial No.: P680A1ZTED010000
-------------------------
Setting up communication with interface 0
Using endpoint 0x01 for message sending ...
Trying to send message 1 to endpoint 0x01 ...
 OK, message successfully sent
Resetting response endpoint 0x81
Resetting message endpoint 0x01
-> Run lsusb to note any changes. Bye.

When I run lsusb - device remains unchanged, it's still 19d2:0154. In /dev directory there is no /dev/ttyUSB0 device.

My modem USB power pin is connected directly to 5V/2A power supply.

When I was installing this modem it 1 year ago on old Raspbian everything just worked. Now im reading one USB modem tutorial after another and... it doesn't work.

New kernel is not supporting that modem or something like that?

3

I still have no idea why usb_modeswitch is not working, but I found that flash drive can be turned off in ZTE modems.

I did it and it worked. Now my modem is seen as 19d2:0017 and some ttyUSBx devices appeared in my system.

  1. Connect modem to Windows machine

  2. Connect to modem (COM port) with terminal (PuTTY or other) (115200bps, Data bits: 8, Parity: None, Stop bits: 1, Flow Control: None).

  3. Send AT commands:

    AT+ZOPRT=5
    
    AT+ZCDRUN=8
    

More details here: ZTE MF110/MF190

More AT commands for ZTE modems: ZTE AT-commandsThis is a featured page


I will not accept my own answer, I still don't know why mode switch is not working.

0

There is a very good description of how to switch various usb modems with usb_modeswitch at https://wiki.ubuntuusers.de/USB_ModeSwitch/. The list mentions the ZTE MF637 modem, so it might work for your modem too.

In my case the solution was to just use the -v, -p, and -M parameters for usb_modeswitch. Before, I used also -V and -P and that did not work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.