-1

i have raspberry pi Type B and i am trying to attach camera into it,

all i have done is upgrading dist and firmware

sudo apt-get update sudo apt-get dist-upgrade sudo rpi-update

all firmware is updated

now according to what i saw commonly in google i have to execute raspistill

raspistill -v

and this is what i've got

raspistill Camera App v1.3.8

Width 2592, Height 1944, quality 85, filename (null)
Time delay 5000, Raw no
Thumbnail enabled Yes, width 64, height 48, quality 35
Link to latest frame enabled  no
Full resolution preview No
Capture method : Single capture

Preview Yes, Full screen Yes
Preview window 0,0,1024,768
Opacity 255
Sharpness 0, Contrast 0, Brightness 50
Saturation 0, ISO 0, Video Stabilisation No, Exposure compensation 0
Exposure Mode 'auto', AWB Mode 'auto', Image Effect 'none'
Metering Mode 'average', Colour Effect Enabled No with U = 128, V = 128
Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000
mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn't be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates

ENOSPC error always showing ,

this is my /etc/modules

w1-therm
w1-gpio pullup=2
i2c-dev
i2c-bcm2708
spi-bcm2708
snd-bcm2835
#lirc_dev
#lirc_rpi gpio_out_pin=7

my /etc/modprobe.d/raspi-blacklist.conf

# blacklist spi and i2c by default (many users don't need them)

#blacklist spi-bcm2708
#blacklist i2c-bcm2708

uname -r

3.12.25+

i cant figure what is wrong with this error, someone know how to solve it? please help me to solve it.

  • did you run the sudo raspi-config and enable the camera support? (plus reboot) – rob Jul 24 '14 at 14:33
  • i have . still not working – hilmanshini Jul 24 '14 at 14:44
  • can you find someone else with a Pi and try it on theirs or borrow another camera? I have two Pi cameras and both a model A & B and never had a problem getting them working. – rob Jul 25 '14 at 7:55
1

This might be issue #435 that the camera doesn't play nice with Dallas 1-wire stuff. Elucidation's post (8th Jan) in that ticket is apparently one to look at (seen a couple of reports stating that particular config worked) - your configuration looks very similar, but for the fact that the "blacklist i2c-bcm2708" line is commented out. You might want to try uncommenting that?

Failing that, try commenting out the 1-wire (w1-*) modules in /etc/modules just to see if that makes a difference. If it does, at least you'll know it is the 1-wire/I2C conflict causing the issue.

  • yep it did good for my Pi, but when all complete , pi stuck at capturing camera 0, and it never give me an image, thanks btw – hilmanshini Aug 3 '14 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.