3

I'm trying to configure my Raspbian to support console output in my native language (Polish). After updating my locale preferences (I chose pl_PL.UTF-8 as my default locale), I ran a test - I typed some non-ASCII characters needed to represent strings in Polish, and saved them into a file:

It seems the default font doesn't support UTF-8, I guess... I downloaded the file and viewed it in a text editor on my Windows machine:

Well, that's exactly what I typed. But when I view the file via the SSH console (PuTTY), this is what I see:

How do I set a UTF-8-compatible font in the "physical" Raspbian console and how do I set up the SSH connection to display the characters properly?

EDIT: I should make it clear that the problem touches all the console output, not only text file contents. This is the lower part of nano's CLI interface:

And below are the correct spellings, taken from some other remote Ubuntu instance:

The same happens to any translated command line tool I run.

EDIT 2: Thanks to Steve Robillard, I set the remote character set in PuTTY to UTF-8, and now all the characters in my SSH console display properly. I didn't think it could be PuTTY's fault, because it was always working correctly with all the other machines I usually SSH into. I also thought the encoding is negotiated automatically... Wrong!

The problem with Raspberry's "physical" console (the one displayed on the screen connected directly via HDMI), however, still remains unsolved.

EDIT 3: Answeing HeatfanJohn's request, here is the output of locale -a:

  • 1
    Assuming all of this is done through Putty have you checked what font putty is using? If not check the putty window translation section - it has an option for the remote character set. – Steve Robillard Jul 27 '14 at 19:53
  • @Steve: Yes, all console screenshots are from PuTTY (except for the first image - that's a screen connected directly to Raspberry). My instance of PuTTy uses Courier New font, which supports all the characters I need. – ksadowski Jul 27 '14 at 20:42
  • @SteveRobillard: And the Translation section had a remote character set setting, which did the trick! Thank you, I now have localized console via SSH :) – ksadowski Jul 27 '14 at 20:45
  • I suggest you write an answer to your own question and accept it. Glad I could help. – Steve Robillard Jul 27 '14 at 21:57
  • What does locale -a display? – HeatfanJohn Jul 28 '14 at 13:19
1

What does locale (without the -a) report (i.e. all the language specific variables and their current values)? I think you should ensure that you have done:

export LANG=pl_PL.utf8
export LANGUAGE=pl_PL.utf8`

in your .bashrc I believe.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.