9

Is there an official MongoDB repo for the Raspberry Pi

Following:

Got this issue:

W: Failed to fetch http://downloads-distro.mongodb.org/repo/debian-sysvinit/dists/dist/Release  Unable to find expected entry '10gen/binary-armhf/Packages' in Release file (Wrong sources.list entry or malformed file)

Notices it's malformed

Fixed but still the same issue

Failed to fetch http://downloads-distro.mongodb.org/repo/debian-sysvinit/dists/dists/dist/10gen/binary-armhf/Packages  404  Not Found

UPDATE #1:

trying this

UGH... Well that took 12 hours to compile and install!

Also have seen this, any feedback?

UPDATE #2:

Looks like this might be worked on officially, but when is more of the question

Vote People!

UPDATE #3

  • 2
    You should answer your own question. There is no official arm version of MongoDB. You should also clarify what you mean by "official." Especially since you link to work being done by Canonical - To my view the only "official" packages come from MongoDB. – Steve Robillard Feb 16 '15 at 5:23
3

You didn't specify OS requirement, though you hint at using Raspbian.

Another option is to use ArchLinux ARM. Arch always has the most up-to-date software available, great support for ARM and for things not available in the official repository, the Arch User Repository.

I see looking at the Arch ARM repository that MongoDB 2.6.8 is available. And if you want 3.0, it's available in the AUR, which makes it pretty easy to install.

(had some additional links but reputation limits prohibits including more than two, so you'll have to do some googling)

1

Looks like this might be worked on officially, but when is more of the question

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.