0

I've tried sudo apt-get install htop as per here. It doesn't return results: E: Unable to locate package python-software-properties.

I've tried sudo apt-get update! Why doesn't this work?

7
  • Try pinging http://www.google.com, http://www.raspberrypi.org, and 8.8.8.8 and editing with the results for each. Also, how are you connecting? Jul 28, 2014 at 21:46
  • ping is fine on all of them. And I'm connecting via ssh on local network. The Rpi is definitely connected to the internet as I have used the browser over tightvncserver Jul 29, 2014 at 12:50
  • Sorry, I meant the Pi. How is the Pi connected? WiFi or Ethernet? Jul 29, 2014 at 13:57
  • Also, run apt-cache search htop then apt-cache search python-software-properties and post the results. As a side note, that post is Linux generic and not Raspberry Pi specific. There simply may not be a python-software-properties package for ARMv6, the ARM version the Pi is run on. Jul 29, 2014 at 14:03
  • One last thing, try running sudo apt-get install software-properties-common. This is a replacement for python-software-properties and, at least in Ubuntu (which, like Raspbian, is based off of Debian) python-software-properties was removed in favor of software-properties-common in late 2012. Jul 29, 2014 at 14:07

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.