2

I am using a raspberry pi model b 512 MB with an Edimax EW-7811Un wifi stick and the raspberry pi camera. Power adapter has 2A/5V. OS is latest raspbian, kernel 3.12.25+. For the wifi stick, I have disabled the power management, also I have set up a cronjob pinging my router once every minute.

However the following happens: After several hours (15 and 18 hours the last times) I can't reach the raspberry pi anymore using wifi. Syslog shows, that the pi is still running. I can't find hints on wifi problems in the syslog, though.

Any ideas, what else I could try? Thanks!

Update:

I have to correct myself. I can still ping the pi, but other connections are not possible, e.g. SSH using Putty ends up with "Server unexpectedly closed network connection" after several seconds. Very strange. Any ideas on this? Thanks!

  • You can try to workaround this and restart your connection when network stops working (there is no ping -> ifdown wlan0 -> ifup wlan0). However thats just workaround... – Kamil Jul 29 '14 at 10:22
  • good hint, i forgot about that and now implemented a cronjob for that. as you already mentioned, solving the problem would be better though ;-) – stefan.at.wpf Jul 29 '14 at 12:56
  • Updated my observations. – stefan.at.wpf Jul 30 '14 at 9:38
  • After "ping is working" update: Have you tried to access other services than SSH? Do you have apache, mysql, samba or something else there? Maybe this is just SSH problem? – Kamil Jul 30 '14 at 19:53
  • A mailserver is running on this system which then also is not working anymore. so seems to be a general problem. i just installed a second pi for testing, only basic raspbian and the wifi stick. in less than 24 hours I'll know, if that works better and therefore is maybe just a problem of my installation. – stefan.at.wpf Jul 30 '14 at 20:26
1

To disable power saving mode, you have to add "wireless-power off" in your "interfaces" file

1/ Type

sudo nano /etc/network/interfaces

2/ Add at the end of file

wireless-power off

3/ Reboot by typing :

sudo reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.