I'm using a RPi Model B as a file server back home. I set it up according to HTG's RPi file server guide, so I'm using SFTP to access the files on it. The RPi is wired to a Linksys router functioning as a hub, which is wired to an Airport Extreme. The Airport Extreme gives the RPi a static IP on the local network, and forwards port 22 to it. I use a free No-IP hostname to access it when I'm not at home. The files are stored on a 160GB HDD, which is inside of a powered enclosure.

Every once in a while, the RPi will stop responding to any attempt to connect to it. I.e., when I try to SSH into it, I receive a "Server is unreachable" error. After powering off and powering back on, it runs fine for a week or two, then dies again. At first, I thought it was a power issue, since I was using a smaller 1A supply, so I got a bigger 2A supply that claimed to be designed for the Pi. However, it still keeps doing it.

The big problem is that I'm ~4000 miles away from home for the next two months. So far I've just been getting my sister to unplug it and plug it back in, but any other troubleshooting has to be done from here, or I have to write a guide for my sister.

Any thoughts?

2 Answers 2


Turns out, the Pi was crashing due to memory issues attributable to torrenting. After running through the logs, I found the familiar "kevent 2 may have been dropped" problem.

I.e., it never was a networking issue, instead a torrenting / memory one. I've since switched torrent clients (from Deluge to Transmission) and decreased my torrenting habits. Will update if things are still messed up.


You could set up a cron job to either reboot the Pi, or restart the SSH/Network service every week or so at a time you know you'll not need it.


0 1 * * * root /etc/init.d/networking restart

will restart the network service at 1am everyday.

My SSH can die after a few hours, luckily i'm in the same room and anyway, I blame the dodgy realtek wireless usb for that.

  • Actually, I just tried resetting the network service via SSH (sudo /etc/init.d/networking restart) and now it's offline again. It only comes back up after pulling the plug and plugging it back in.
    – Marshall
    Commented Jul 31, 2014 at 18:39
  • in that case replace networking restart with sudo reboot?
    – kolin
    Commented Aug 1, 2014 at 7:04
  • Just figured this out yesterday: Resetting the network service using "sudo /etc/init.d/networking restart" via SSH makes it so you can't reconnect. The proper way to reset networking when connected via SSH, as I discovered after some googling, is "sudo ifdown eth0 && sudo ifup eth0". That way, my SSH session is able to reconnect at the end.
    – Marshall
    Commented Aug 5, 2014 at 7:20
  • So you have solved your problem? Commented Aug 6, 2014 at 16:55
  • Not quite. I thought I had, then it died again. I surfed the logs and found some problems, details to come tomorrow.
    – Marshall
    Commented Aug 22, 2014 at 7:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.