1

I have a RPi Model B, and the green LED is just a small dot. I have already checked all the steps at http://elinux.org/R-Pi_Troubleshooting, but none work.

Any tips?

5
  • What output do you get if you connect it to a monitor?
    – Bex
    Aug 7 '14 at 14:11
  • @Bex Isn't it likely that he already had it connected to a monitor?
    – Beta Decay
    Aug 7 '14 at 14:23
  • 1
    What is the voltage measured between TP1 and TP2? help Aug 7 '14 at 16:15
  • Is it working yet?
    – Beta Decay
    Aug 8 '14 at 9:23
  • I did connect it to a tv using the tv-out. No signal is what my TV says. Not working yet. Voltage between TP1 and TP2 is 4.99V.
    – Rupin
    Aug 8 '14 at 15:17
2

I suspect your SD card's image is not correct. If you have a Pi that boots correctly, try its card. If not, try rebuilding the image.

I don't know what version of Linux you're trying to use, so I don't know the specifics. But you might be able to take your SD card and mount it in an OS that can read it and look at the /var/log/dmesg.log or maybe /var/log/boot.msg on the card. You should be able to find the boot messages if the boot process even starts.

1
  • Using Windows, and used the Win32DiskImager utility to loadup the SD card. I used "Run as Admin.." option while starting the program.
    – Rupin
    Aug 8 '14 at 15:19
2

Since your LED is 'just a small dot' it could be that you have a faulty power source. Try a different power cable (a Blackberry charger is what I use) and test your current power source on a different device.

If that doesn't work, then you probably have something wrong with either your Pi or your SD card (as mention in another answer).

Are you sure you've gone through everything because this sounds awfully like your problem...

2
  • Voltage between Tp1 and Tp2 is 4.99V. I suspect the SD card to be faulty, but when I tried using an SD card from my camera, it still did not boot.
    – Rupin
    Aug 8 '14 at 15:18
  • @Rupin Might be your image... What are you using? NOOBS or just plain Raspbian Wheezy?
    – Beta Decay
    Aug 8 '14 at 15:19
1

Physical pins on the SD card slot were mangled beyond repair. I need to solder another SD card holder.

Looks like that was the problem

1
  • 1
    Would be most helpful if you mark this question as solved.
    – Diego
    Aug 14 '14 at 12:03
0

I would use a combination of the answers from Paxton Sanders and user12321. I would try a different power source (I use an iPhone charger with a micro usb cable) and a different image on another SD card. You can get a number of different images for your SD card here: http://www.raspberrypi.org/downloads/

Using a process of elimination you can identify the fault, and then rectify it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.