I have a Pi running Raspbmc by the TV and a desktop computer in the study. For a while, I had the TP-Link gigabit router next to the Pi and the desktop connected via household wired network cables. The household network was poorly configured and only getting 10Mbps speeds. I redid the network outlets making them gigabit-capable and moved the router into the study. Now I get 100Mbps speeds as measured by iperf (the Pi only supports 100Mbps). But for some reason Raspbmc's networking has become slower! Before, when I started a video it would spin up in a second or two. Now it takes 15 to 30 seconds. And if I try to switch to another video while one video is playing, playback stutters and slows down to nearly a halt.

Could the Pi's networking slow down because of its distance from the router? This is the only explanation I can think of, because nothing else has changed other than the router location and the added support for 1000BASE-T in the wiring.

To be clear about the wiring, previously the house was wired with only 2 twisted pairs being used per port. Being only 10BASE-T the maximum speed was 10Mbps. I rewired/recapped all the network cables so they now use all 4 twisted pairs and support gigabit speeds. I confirmed gigabit is working between two computers that have gigabit support. The Pi only has 100Mb support which I also confirmed is working.

EDIT: output of ifconfig:

eth0  Link encap:Ethernet  HWaddr b8:27:eb:0b:32:d8  
      inet addr:  Bcast:  Mask:
      inet6 addr: fe80::ba27:ebff:fe0b:32d8/64 Scope:Link
      RX packets:125183 errors:0 dropped:0 overruns:0 frame:0
      TX packets:24397 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:170776152 (162.8 MiB)  TX bytes:2928810 (2.7 MiB)

lo    Link encap:Local Loopback  
      inet addr:  Mask:
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:571 errors:0 dropped:0 overruns:0 frame:0
      TX packets:571 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:58730 (57.3 KiB)  TX bytes:58730 (57.3 KiB)


  • 1
    The Pi is connected using a ethernet cable. Right?
    – Kangkan
    Commented Aug 12, 2014 at 10:52
  • Did you try to transfer a huge file via scp? I just want to exclude problems with XBMC, SD card and any other minor invisible change. Send a video using scp and check the average speed. See if matches with megabit connections. Commented Aug 12, 2014 at 13:36
  • Can you add some more information as well such as if you are running overclocked or not, where is the video streaming from, have you tested a different switch, what distribution of Raspbmc are you on and have you ran updates for the nightly builds? Commented Aug 12, 2014 at 17:51
  • 1
    @Kangkan the 100Mbps light is on and yellow. I'm pretty sure I'm connected at 100Mbps. What I've noticed however is that opening videos inside of directories with lots of videos takes longer than opening videos in directories with fewer videos. Commented Aug 13, 2014 at 9:58
  • 1
    how about using NFS, SSH has far more overhead. In my LAN, HD movies stuttering via SSH are fine via NFS (the same hardware, the same LAN)
    – jet
    Commented Aug 14, 2014 at 16:39

3 Answers 3


how about using NFS, SSH has far more overhead. In my LAN, HD movies stuttering via SSH are fine via NFS (the same hardware, the same LAN)


I would recommend trying to overclock the RPi. This guide has how to overclock an RPi with RaspBMC. Basically using SSH from another machine on your network edit the config.txt file. I highly recommend reading about overclocking before just plugging in values. Just from my experiences I have mine running at 900MHz following this post, the second response but with an overvolt of 2. I'm able to stream HD movies with very little hesitation.

Also just in general, having a lot of files in a single folder increases load times anyways. I'd suggest some sort of subdivision of folders. I try to limit my folders to less than 20 items.

  • 1
    As a side note, it is possible that when your network was running at 10MBps the Pi was able to keep up but now the higher bandwidth is straining the Pi a bit and it's having to pre-cache some of the data. Commented Aug 13, 2014 at 19:45
  • I tried overclocking to 900MHz but there's no noticable difference. HD streaming works for me too, but starting videos sometimes takes over a minute. Commented Aug 14, 2014 at 5:16
  • I do notice that xbmc.bin is regularly using around 70% CPU and dropbear is using another 15%. I also tried putting a directory with almost 400 videos on an external hard drive to compare speed. The video that took over a minute to start playback over the network only took about 8 seconds from the external drive. Commented Aug 14, 2014 at 5:42
  • What is your memory split setting? Commented Aug 14, 2014 at 11:17
  • 1
    Try 450MHz for the SDRAM. Memory split defines how much memory is allocated to the system and the GPU. Here's a link to a discussion on it: raspberrypi.org/forums/viewtopic.php?f=91&t=58245 Commented Aug 15, 2014 at 12:41

Disable the firewall in Raspbmc Settings

Should this still not resolve -- please email me

Sam Nazarko


  • The op says there is no change in the Pi except the LAN cable connections. How can this be an answer?
    – Kangkan
    Commented Aug 13, 2014 at 13:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.