0

I blew my B+ up in less than 2 days.I want to know what went wrong to prevent it from happening again.

What I remember doing:

  • I was making GPIO to run for my RC car(1A motors), I did use TIP122 and a dpdt relay.
  • Something was not right(the motors ran with output set to false)
  • To test it, I connected an LED to one of the GPIOs and the other end to the ground.(no resistances etc.)

This is when I think my raspberry Pi blew up.

This is what happens now:-

-Sometimes the red light (power) glows normally, sometimes, its very dim, sometimes it doesnt glow at all.

  • The green light shows a similar erratic nature.
  • The mouse sometimes works, sometimes it doesnt.

In this scenario, what are the things that could have gone wrong that blew my Pi? Also, is there ANY thing I can do to repair it(changing parts, etc)?

If more information is needed, I will be happy to provide it. Thank you

  • I'd use a fresh copy of the OS and set up a basic LED for each GPIO pin to test. (I actually keep this made up on an extra breadboard, as a "test-rig", so that I can just plug it in to test.) You can kill pins by applying the wrong voltage, but it usually doesn't have the symptoms you're describing (at least it hasn't happaned that way for me.) – Tyson Aug 15 '14 at 16:55
  • the thing is,i tried a new copy of NOOBS, keyboard/mouse doesnt work – harveyslash Aug 15 '14 at 17:08
  • ok, i JUST tried your suggestion, and the installation started(the mouse/keyboard works suddenly) , but the green light stops ater 10 mins into the installation, and I get a black screen. now what ? – harveyslash Aug 15 '14 at 17:18
  • 1
    The LED test may be misleading. That might have killed a LED and taken out one or two gpios by excessive current but the damage would be limited. If you are lucky the 2 amp polyfuse blew because the motors were drawing too much power. The polyfuse should recover in a day or so. If you want practical help you'll need to give precise details of the connections you have between the Pi gpios and the motors etc. – joan Aug 15 '14 at 17:21
  • 1
    It sounds like your polyfuse may have drawn too much current (were you powering the motor via the GPIO?) and cut off power - typically it will fix itself in a few days (freezer + plastic bag) can speed this up, but before you do that to confirm, have you measured the voltage input and then again between the two test points? – user2813274 Aug 15 '14 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.