2

I have been having a few frustrating hours trying to get iptables to work. I have updated and upgraded my raspbian. I have iptables V1.4.14 installed.

# iptables -A INPUT -i eth1 -p tcp -m tcp --dport 443 -j ACCEPT         
iptables: No chain/target/match by that name.

I get the same if I try a DNAT instruction. I found reference to the file below - which looks pretty minimal:

# cat /proc/net/ip_tables_targets                                       
MASQUERADE
ERROR

This is my current configuration:

#iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination
ACCEPT     all  --  10.192.128.0/17      anywhere
ACCEPT     all  --  anywhere             anywhere

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

It seems pretty basic what I think I am trying to do, maybe I'm missing something basic?

1

So, after more research, I found someone that had a similar problem (http://forum.openvz.org/index.php?t=msg&goto=8429&), part of their resolution was to load the xt_tcpudp module. This led me in a different direction - I found I was having issues with modprobe. uname -a showed a level of 3.10.25, however there was no lib/modules/3.10.25+ - the directory in modules was several revisions higher. I tried using rpi-updater to straighten things out. Still no joy, in fact it seemed to break some other things. lsmod showed nothing loaded. So, today I used rpi-updater with the git sha of the 3.10.25 commit to reinstall the 3.10.25 version. After this, iptables now seems to work fine, lsmod shows a bunch of modules loaded.

Hope this may help someone else out one day :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.