1

I'm Italian so sorry if my english isn't that good.

I've bought for a week a new Raspberry Pi B+ and a wifi dongle Edimax ew-7811un. I've configured the /etc/network/interfaces and the /etc/wpa_supplicant/wpa_supplicant.conf files and now the RasPi can connect to the Internet without problems with a static ip. When I try to connect my mac to the RasPi with ssh over the wifi I can establish the connection but if I write a command in my terminal the whole wifi network drops for all the connected devices in the house and after 30 seconds restarts. Then I tried to connect the RasPi to the internet with an Ethernet cable after I plugged out the dongle and then i could connect my mac with ssh without problems. But I need to have the RasPi connected only via wifi and not with the ethernet cable. So how can I solve? Thanks in advance :)

This is my interfaces file:

auto lo

iface lo inet loopback
iface eth0 inet static
address 192.168.1.115
netmask 255.255.255.0
network 192.168.1.1
broadcast 192.168.255
gateway 192.168.1.1

auto wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet static
address 192.168.1.115
netmask 255.255.255.0
gateway 192.168.1.1
network 192.168.1.1
broadcast 192.168.1.255

And this is the wpa_supplicant.conf file:

    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1

    network={
            ssid="secret-ssid"
            psk="secret-psk"
            proto=WPA
            key_mgmt=WPA-PSK
            pairwise=TKIP
            auth_alg=OPEN
    }
  • Congratulations, you built a wlan bomb! - please post the relevant lines form dmesg output – Florian Fida Aug 21 '14 at 1:00
  • What do you mean with relevant? Which lines should I post? I've never used that command so I don't know what I should search for. Sorry and thanks for the answer :) – Zimmlar Aug 21 '14 at 14:48
  • try dmesg | grep wlan0 – Florian Fida Aug 21 '14 at 16:34
  • btw, is using wicd-curses an option for you? its pretty good on guessing the right configuration... Here is a (random) tutorial if your interested: blog.ubidots.com/setup-wifi-on-raspberry-pi-using-wicd – Florian Fida Aug 21 '14 at 16:41
  • @FlorianFida dmesg | grep wlan0 doesn't give a response and with wick-curses I can't connect – Zimmlar Aug 22 '14 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.