0

I am using a raspberry pi b+ with raspbmc as a distribution. I'd like to make my raspbmc to run as a router so for this i have bought a wifi dongle ( Edimax W3110MI, based on RT5370 chipset). To configure the pppoe connection settings i use pppoeconf wizard which is straight forward but my problem is that it does not connect on boot. I mean I have selected yes on the question asking if i want to connect on boot time but it does not work. I have to go through pppoeconf again. My entry in /etc/network/interfaces looks like this:

auto eth0
iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
auto dsl-provider
iface dsl-provider inet ppp
pre-up /sbin/ifconfig eth0 up # line maintained by pppoeconf
provider dsl-provider

Any help will be apreciated.

  • I am not sure why you would want to use the Pi as a router (dedicated routers are cheap enough) but why Raspbmc? – Milliways Aug 21 '14 at 10:48
  • @Milliways because i'd like to use it as media center also and i want as few power supplies into socket as possible.... – piuser Aug 21 '14 at 11:07
1

This is a quite old question and probably obsolete because raspbmc is supeseded by osmc now, but I'll answer it any way because I've been struggling with the same problem some time ago.

The reason the setup proposed is not working is because raspbmc does not use that particular file. The network settings in raspbmc are managed by D-Bus and are stored in a specific file which can be managed in the UI of raspbmc.

If you delete that settings file it'll be restored automatically. AFAIK it is impossible to activate the manual settings because the D-Bus managed file is always activated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.