0

Using kali linux for this.

I went into the "Network Connections" and created a new connection under "Wired" and set it to "Shared to other computers" under the "IPv4" tab and it doesn't work. When I plug it into my Mac it shows the ip is self-assigned. Now when I load up kali linux on my laptop and do the same exact thing, it works. What am I doing wrong? Or is there an easier way to set this up?

EDIT: Tried using bridge-utils by running the following commands:

brctl addbr br0
brctl addif br0 eth0 eth1

and get an error message: Operation not supported

  • Is your Pi supposed to be a DHCP server that assigns your mac an IP address via Ethernet? (Not too familiar with Kali) – user2813274 Aug 23 '14 at 18:44
  • I just set it up like I explained on the full desktop version of kali but yeah it didn't work. I did try use bridge-utils , is that a good option? – Aaron Aug 23 '14 at 19:46
  • OpenWRT supports raspberry pi, maybe that's an option for you: code.google.com/p/raspberrypi-openwrt – Florian Fida Aug 23 '14 at 22:22
  • Please Clarify: You have a PI with ethernet and wifi. And you want to share the Ehternet with a desktop PC? Or perhaps: You have a PI with ethernet and wifi. And you want to share the wifi with other wifi devices? – j0h Aug 24 '14 at 14:20
  • 1
    I'm doing this right now, so I can tell you how I do it, at least. I enabled internet sharing via ethernet on system preferences -> sharing, connected the pi and the mac via ethernet, then installed netatalk on the pi (sudo apt-get install netatalk), then started it up (sudo /etc/init.d/netatalk start), and on my shared section in finder I saw 'raspberrypi'. I went on 'Connect as...', logged in, and that was all. Very fast process. – BenjaminJB Aug 24 '14 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.