0

I've been trying to setup my raspberry pi and preconfigure the SD card for wifi before plugging it into my pi. I started using the instructions here. Originally, my pi was already preconfigured for XBox Media Center when I bought it, but I wiped the SD card (SanDisk) when I followed these instructions. In the first article, the author says that once Raspbian is installed on my SD card, I should be able to use 'sudo nano /etc/network/interfaces' to access the interfaces file and begin configuring the Pi for wifi. However, when I try this command, Nano clearly indicates that this is a new file in a new directory, so it did not exist after the Raspbian installation. I changed directories into the disk (/Volumes/boot/) and do not see the etc directory anywhere. Instead I have:

bootcode.bin
cmdline.txt
config.txt
fixup_cd.dat
fixup_x.dat
issue.txt
kernel.img
LICENSE.oracle
start_cd.elf
start_x.elf
start.elf

I cd'd into bootcode.bin, but did not find the etc folder. I've tried searching for what contents should be in the SD card after I complete the installation, but every guide just shows what the output should look like after running the dd command, then says 'plug in the pi and boot it'. I don't have a monitor, keyboard or mouse available to do this so I have to run a headless setup. Can someone please explain if I've installed this incorrectly?

  • What OS are you doing this on? – Milliways Aug 27 '14 at 23:46
  • "before plugging it into my pi"--the raspbian install doesn't complete until you boot it in your pi. You need to hook a keyboard and monitor initially even if you plan to run it headless later. Some of the configuration simply has to be done live. – Tyson Aug 28 '14 at 0:30
  • Tyson, thanks for the info. I had a feeling... @Milliways, this is on OSX Mavericks – Sandwich Heat Aug 28 '14 at 0:48
0

OSX does not support Ext4 so you won't be able to edit /etc/network/interfaces on the Pi.

'sudo nano /etc/network/interfaces' would be trying to access the file on your Mac.

You will need a Linux machine if you want to do this, but it will be easier just to boot the Pi.

  • What about a Linux virtual machine? I have a couple of Ubuntu machines. – Sandwich Heat Aug 28 '14 at 1:16
  • Actually, I think I can figure something out here. I've found a few articles. I'll post back in comments once I've tried it out. Thanks! – Sandwich Heat Aug 28 '14 at 1:39
  • You could use a virtual machine. You have to make sure it has access to the SD Card. I have done this with hard discs, but not SD. You could always boot to a Linux disk. – Milliways Aug 28 '14 at 1:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.