1

I have problem, when I connect into raspberry pi B+ keyboard its outputing wrong characters. ex. When I trigger S it return O. If I connect with SSH to this RPi it works normal, keyboard language is CZ

2
  • What os are you running? What locale is the os set in? Do you have a /etc/default/keyboard-file, and if so, what does it say? Did you research man keyboard?
    – Bex
    Sep 2, 2014 at 7:50
  • raspbian latest Sep 2, 2014 at 7:55

1 Answer 1

2

You need to reconfigure you keyboard settings.

sudo dpkg-reconfigure keyboard-configuration

Follow the prompts. Then restart your RasPi.

reboot

Or:

sudo nano /etc/default/keyboard

look for

XKBLAYOUT=

and place "cz" there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.