2

I have a pi, running raspbian connected to a USB3 drive. I run a samba server, minidlna, transmission-daemon.

I had some trouble initially setting up the transmission-daemon to work from outside of the wan. Eventually it worked.

Then I installed Apache2, it worked for a time but now the transmission web gui is timing out when I want to connect to it remotely.

I found this command, it might be of some use.

root@raspberrypi:~# transmission-remote -t all -S
Unexpected response: <h1>401: Unauthorized</h1>Unauthorized User: deflate, gzip

Am I correct when I say the config file is in /etc/transmission-daemon/settings.json ?

I manually told transmission to use that folder.

this is my config file:

root@raspberrypi:~# cat /etc/transmission-daemon/settings.json 
{
    "alt-speed-down": 50, 
    "alt-speed-enabled": false, 
    "alt-speed-time-begin": 540, 
    "alt-speed-time-day": 127, 
    "alt-speed-time-enabled": false, 
    "alt-speed-time-end": 1020, 
    "alt-speed-up": 50, 
    "bind-address-ipv4": "0.0.0.0", 
    "bind-address-ipv6": "::", 
    "blocklist-enabled": false, 
    "blocklist-url": "http://www.example.com/blocklist", 
    "cache-size-mb": 4, 
    "dht-enabled": true, 
    "download-dir": "/mnt/ext/pi-downloads", 
    "download-limit": 100, 
    "download-limit-enabled": 0, 
    "download-queue-enabled": true, 
    "download-queue-size": 5, 
    "encryption": 1, 
    "idle-seeding-limit": 30, 
    "idle-seeding-limit-enabled": false, 
    "incomplete-dir": "/root/Downloads", 
    "incomplete-dir-enabled": false, 
    "lpd-enabled": false, 
    "max-peers-global": 200, 
    "message-level": 2, 
    "peer-congestion-algorithm": "", 
    "peer-limit-global": 240, 
    "peer-limit-per-torrent": 60, 
    "peer-port": 51413, 
    "peer-port-random-high": 65535, 
    "peer-port-random-low": 49152, 
    "peer-port-random-on-start": false, 
    "peer-socket-tos": "default", 
    "pex-enabled": true, 
    "port-forwarding-enabled": true, 
    "preallocation": 1, 
    "prefetch-enabled": 1, 
    "queue-stalled-enabled": true, 
    "queue-stalled-minutes": 30, 
    "ratio-limit": 2, 
    "ratio-limit-enabled": false, 
    "rename-partial-files": true, 
    "rpc-authentication-required": true, 
    "rpc-bind-address": "0.0.0.0", 
    "rpc-enabled": true, 
    "rpc-password": "{4e7296370947f56a55ae6ab383bddb81d4fcb85916Lyz.a5", 
    "rpc-port": 9091, 
    "rpc-url": "/transmission/", 
    "rpc-username": "transmission", 
    "rpc-whitelist": "127.0.0.1,192.168.*.*", 
    "rpc-whitelist-enabled": false, 
    "scrape-paused-torrents-enabled": false, 
    "script-torrent-done-enabled": false, 
    "script-torrent-done-filename": "", 
    "seed-queue-enabled": false, 
    "seed-queue-size": 10, 
    "speed-limit-down": 100, 
    "speed-limit-down-enabled": false, 
    "speed-limit-up": 100, 
    "speed-limit-up-enabled": false, 
    "start-added-torrents": true, 
    "trash-original-torrent-files": false, 
    "umask": 18, 
    "upload-limit": 100, 
    "upload-limit-enabled": 0, 
    "upload-slots-per-torrent": 14, 
    "utp-enabled": true
}

Previously reinstalling the daemon worked when it suddenly decided to die on me. Now however, a reinstall isn't doing the trick anymore.

When I go to :9091 the browsers just keeps on loading. I'm not home right now but the port is open and forwarded, and I can ssh to the pi.

UPDATE When I came home, tried it on my cellphone locally, it didn't work. Then I went up to my room and tried on my gaming desktop and both lan and wan access work. Tried on my phone with hostname:9091, nothing. Tried on my phone again with localIP:9091, it works. Tried on my phone with wan hostname:9091, it works.

I'm not a networking kind of guy but this isn't working properly and I would like to know why.

UPDATE 2:

Could it be that my ISP is the culprit? (they block many ports for "security reasons") Or could it be that the network at my office has something to do with it. Is there a proper way to test this?

0

After doing some more research it seems that my ISP is only a part of the problem. Some networks (like schools and office lan's) block the access to anything hosted on a "home connection".

The problem isn't RasPi or config related.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.