3

I have three possible internet connections on my pi:

eth0 (unused) wlan0 - a cheapo dongle usb0 - my Android phone.

When I switch on my Pi, it searches for an ethernet connection for a long time, which, seeing as it's disconnected, never happens.

It repeatedly spits out the result...

DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval...

...over and over again for about 1-2 minutes, before booting normally. Whilst this isn't a problem per se, it is annoying and simply slows me down. Seeing as I'm trying to use the Pi in a very portable configuration, this is a bit of a nark.

Does anybody know how to stop this happening?

Thanks!

P.S. I'm on Raspbian Wheezy

  • Do you need to disable completely eth0, or you just want to make it discovering the network only if the other interfaces failed? – Morgan Courbet Sep 4 '14 at 13:49
  • I don't want to disable it, I just don't want it to bother looking for an ethernet connection at all on startup – Guy Stimpson Sep 4 '14 at 13:56
5

I have my own answer. Again. I have to stop asking I think.

As suggested above, I needed to edit the /etc/network/interfaces, but I just changed auto eth0 to auto wlan0 so it picks up the wifi instead.

  • You mean in /etc/network/interface, right? – Morgan Courbet Sep 4 '14 at 14:06
  • Yes, I do, sorry, will clarify... – Guy Stimpson Sep 4 '14 at 14:08
  • Edited my answer :) – Guy Stimpson Sep 4 '14 at 14:10
4

Simple! Go to /etc/network/interface and add:

auto eth0
iface inet eth0 manual

And reboot.

  • It's still doing it :/ – Guy Stimpson Sep 4 '14 at 13:57
3

There is a option on the raspi configurations to NOT wait for a ethernet connection to establish and just boot normaly. Its a checkbox. Hope it helps someone

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.