3

I'm trying to run Rasberry Pi on Qemu (using a Linux Kernel on Mac osX), and I'm working on getting the example programs running (examples in /opt/vc/src/hello_pi). As of now, only the hello_world program works. If I try running other programs like hello_video or hello_triangle, it gives me an error saying "failed to open vchiq instance".

I tried some of the options suggested (How can I permanently fix /dev/vchiq permission errors?).

I logged onto root and tried

echo 'SUBSYSTEM=="vchiq",GROUP="video",MODE="0660"' > /etc/udev/rules.d/10-vchiq-permissions.rules

usermod -a -G video [pi]

I also tried "chmod a+rw /dev/vchiq" and "/opt/vc/bin/vchiq_test -f 1"

However, it still gives the same error while trying to run the program. Any ideas? Is this happening because of the qemu emulator and is there any way to fix it?

Thanks!

3

QEMU does not emulate the Videocore hardware; programs that try to interface with it through VCHIQ will fail. It looks like this QEMU fork might get you closer to proper emulation, but I wouldn't get my hopes up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.