2

exact with the minutes but wrong with the hours. Mon Sep 8 08:54:44 BST 2014. When actually it is 20:54.
I did : sudo /etc/init.d/ntp restart at least ten times no avail. My raspi activates a timelapse camera and has been working for month without any problem with the correct time and all of a sudden this problem occured without any intervention. Now the camera instead of taking a picture at 10:00, take it at 22:00....Too bad it's dark.

6
  • 2
    Did you set /etc/localtime according to your timezon. E.g. (on Archlinux) ln -s /usr/share/zoneinfo/Europe/Berlin /etc/localtime Ok, your date states BST looks like time is already localized. Mmmh.
    – Ghanima
    Commented Sep 8, 2014 at 20:17
  • IS this Raspian or another distro?
    – rob
    Commented Sep 9, 2014 at 7:30
  • My distro is Raspbian wheezy. And the timezone is well configured through Raspi-Config. Never seen this kind of problem ! Commented Sep 9, 2014 at 10:04
  • What is the output of ntpdate -du pool.ntp.org
    – Craig
    Commented Sep 9, 2014 at 16:21
  • Is the pi connected to a network via ethernet cable or wifi? If not, ntpd can't update and the pi has no hardware timeclock.
    – Tyson
    Commented Sep 11, 2014 at 1:29

1 Answer 1

2

Considering that the RPi has got no Real Time Clock and starts at January, 1st, 1970 every reboot, I assume that your ntpis working fine. Check with date -u the system time in UTC and compare to reality. It's most probably right (unless you used date -s to set the time manually).

The guess would be that your timezone settings are wrong. Please check the symbolic link /etc/localtime or remove it and create it newly according to your timezone by ln -s /usr/share/zoneinfo/<your-timezone-goes-here> /etc/localtime.

6
  • 1
    Note that if you use Raspbian, you can run sudo dpkg-reconfigure tzdata to change easily the timezone. Commented Sep 9, 2014 at 8:59
  • Sure. It's noteworthy that the use of configuration tools might overwrite manual settings. (Also a possible error in this case.)
    – Ghanima
    Commented Sep 9, 2014 at 9:10
  • I did: date -u and the result is: Commented Sep 9, 2014 at 10:08
  • and the result is: Mon Sep 8 22:06:10 UTC 2014 when it is really 11:06 ...a real mystery! Commented Sep 9, 2014 at 10:09
  • And /etc/timezone, confirms : Europe/London Commented Sep 9, 2014 at 10:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.