2

I'm trying to wire up a DS1307 RTC to my Model B Pi. I'm following the diagram as shown in this crude image enter image description here and I've also tried it like this

but it isn't recognized by the Pi. When I run

i2cdetect -y 1

I don't see anything registered. When I wire up a complete RTC I bought on ebay, I see it registered as expected. What am I doing wrong?

Parts used:

  • Have you tried the complete circuit with battery and crystal? – Steve Robillard Sep 9 '14 at 5:11
  • Sorry, I should ahve put that. The crude diagram I put up doesn't show the batt hookup, but i tried it with the full DIP wired up, even trying a few things on the OUT pin. – DustinDavis Sep 9 '14 at 5:46
  • 1
    Loose wire? Try swapping SDA/SCL. – joan Sep 9 '14 at 9:53
  • @joan that's what it was. I used a different breadboard and I got it working. – DustinDavis Sep 9 '14 at 14:23
  • @DustinDavis A loose wire? – joan Sep 9 '14 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.