0

So I got the Raspberry Pi B+ about 3 weeks ago and it hasn't been functioning 100% correctly... I have a PiHub to power my ehdd (1tb WD Elements), Wifi Adapter Realtek 8188CU, and (usually) the raspberry pi as well. Then I have a Rii i8 Mini Wireless dongle in the Raspberry Pi.

This set up was working fine until yesterday when it seems while my pi can boot (powered off the PiHub) the Wifi Adapter and ehhd isn't showing up... and interestingly enough, neither is my Rii i8 in the Rasp Pi. I've tried messing around with the ports (what's plugged in where) and found that the Rii i8 works if I unplug the PiHub USB connector from the Pi. I've tried powering the Raspberry Pi and PiHub separately but to no avail as well.

Not quite sure what's going on, and the annoying part is, I've been working on setting up Raspbian for a while and don't want to lose my progress. I've searched the forums and the googles about this problem, but I'm coming up rather dry :\ Any ideas on what's going on? Help is much appreciated :3

(sorry if this seems really disorganized, I have a bit of a writing disability :I)

  • 2
    Hello Henry, and welcome to the RPi.SE community! I am afraid that anybody won't read your question as it is difficult to read. I think it may be a good idea to make some space in your text by splitting it into paragraphs. Much more readable, and you will have more chance to get answers ;-) – Morgan Courbet Sep 11 '14 at 9:43
  • Are you assuming that the PSU is supply sufficient voltage or have you tested it? – Steve Robillard Sep 11 '14 at 9:45
  • @SteveRobillard I mean I've read online that the PiHub gives sufficient voltage (5V). It is the "official" Raspberry Pi USB Hub. Otherwise, how could I test it :x – Henry L Sep 11 '14 at 9:53
  • 2
    Just because it says it outputs a specific voltage and is designed for the Pi does not mean that it is putting out that voltage parts do go bad. Follow these instructions to verify the voltage elinux.org/R-Pi_Troubleshooting#Troubleshooting_power_problems – Steve Robillard Sep 11 '14 at 10:28
1

I never properly updated this, but the solution I found to this was that the USBA/USBB Cable leading from the PiHub to the Raspberry B+ was faulty. After I replaced this cable, everything seemed to work fine! Good luck all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.