5

I'm Trying to get TP-link's TL-wn725n V2 Nano USB adapter working with my Raspberry PI and an running into problems. I've read a few posts, but an getting myself confused.

  • I can SSH via Ethernet to the PI

I've:

1) uname -a which gives

Linux raspberrypi 3.12.28+ #712 PREEMPT Tue Sep 16 15:49:13 BST 2014 armv6l GNU/Linux

2) lsusb which gives

Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. 
Bus 001 Device 004: ID 0bda:8179 Realtek Semiconductor Corp. 
Bus 001 Device 005: ID 1a2c:0002 

3) The current network setup worked prefectly with this adapter but I think I need to find the correct driver to install for the current adapter.

4) I've found this, but it only lists drivers up to Linux version 3.12.26 and I'm on 3.12.28.

Can someone please point me in the correct direction for the correct driver and how to install it?

  • 1
    I clicked on the last page on that post(13) and there was someone from just a few days ago who had made available a precompiled version for 3.12.28, beware these are dropbox etc. links and could contain anything. – rob Sep 17 '14 at 12:52
  • How can I verify if this is safe? – reggie Sep 17 '14 at 12:56
  • you cannot. I am guessing that somewhere in that post is the detailed instructions to compile the module for your kernel version, your best bet if you are not willing to use one of the community supplied packages is to roll your own. That of course has its own risks and time sinks. – rob Sep 17 '14 at 14:50
  • 1
    try this link to install driver from source: raspberrypi.stackexchange.com/questions/17187/… – Makhlouf GHARBI Sep 17 '14 at 16:05
4

by supergordon » Tue Sep 09, 2014 3:20 pm Hello,

there are no drivers for 3.12.28+, so I compiled them. Works well.

http://gordon.d4rc.net/8188eu_3.12.28.zip readme.txt contains quick installation instructions

This from supergordon worked for me:

wget gordon.d4rc.net/8188eu_3.12.28.zip

unzip 8188eu_3.12.28.zip

sudo cp rtl8188eufw.bin /lib/firmware/rtlwifi

sudo install -p -m 644 8188eu.ko /lib/modules/3.12.28+/kernel/drivers/net/wireless

sudo insmod /lib/modules/3.12.28+/kernel/drivers/net/wireless/8188eu.ko

sudo depmod -a

sudo reboot

Then I could set up connection with WiFi Config (wpa_gui)

0

You can compile you own driver on linux by following these instructions http://github.com/daber/rtl8188eu/blob/master/README.txt

Or download precompiled (this requires a bit of trust ;P ) https://dl.dropboxusercontent.com/u/22460600/rtl8188_rpi_drivers/rtl8188eu_3.2.28plus.zip

protected by Community Oct 15 '14 at 8:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.